WordPress Element Pack Pro plugin < 7.19.3 - Arbitrary File Read and Phar Deserialization vulnerability
Priority LOW 37CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Deserialization of Untrusted Data vulnerability in BdThemes Element Pack Pro allows Path Traversal, Object Injection.This issue affects Element Pack Pro: from n/a before 7.19.3.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00523 44th percentileScored 2026-11-07
Fix Fixed Element Pack Pro (BdThemes): 7.19.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Element Pack Pro (BdThemes) Fixed in 7.19.3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-33568
- 2026-10-03 Alias added: GHSA-hf8f-vq3m-wfg2
References
More bdthemes Element Pack vulnerabilities
- TI-2024-10178 Element Pack Elementor Addons < 5.10.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-09719 Element Pack Elementor Addons < 5.10.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-20220 WordPress Element Pack Lite plugin <= 5.5.3 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-02773 Information disclosure in bdthemes Element Pack – Widgets, Templates & Addons for… CVSS 3.1HIGH 7.5
- TI-2025-07410 Cross-site scripting in bdthemes Element Pack – Widgets, Templates & Addons for Elementor CVSS 3.1MEDIUM 5.4
- TI-2024-03665 Element Pack Elementor Addons (Header Footer, Template Library, Dynamic Grid & Carousel… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-33568 · CVE Program
- CVE-2024-33568 · NVD
- FIRST EPSS
- GHSA-hf8f-vq3m-wfg2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences