AI-Engine < 2.6.5 - Admin+ SQLi
Priority HIGH 67CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.
Summary
The AI Engine WordPress plugin before 2.6.5 does not sanitize and escape a parameter from one of its RESP API endpoint before using it in a SQL statement, allowing admins to perform SQL injection attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00613 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed AI Engine (Unknown): 2.6.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | AI Engine | before 2.6.5 | 2.6.5 | Patch available | CNA |
- AI Engine VendorUnknown Affected before 2.6.5 Fixed in 2.6.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:meowapps:ai_engine:*:*:*:*:*:wordpress:*:* | before 2.6.5 | Vulnerable | tigroumeow |
- cpe:2.3:a:meowapps:ai_engine:*:*:*:*:*:wordpress:*:* Versions before 2.6.5 Vulnerable ·tigroumeow
Remediation
- Fix · CNA AI Engine (Unknown) Fixed in 2.6.5
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10499
- 2026-10-03 Alias added: GHSA-5w62-ppvg-pwpq
References
More tigroumeow Ai Engine vulnerabilities
- TI-2023-28063 WordPress AI Engine plugin <= 1.9.98 - Unauthenticated Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-05988 AI Engine < 2.5.1 - Admin+ RCE CVSS 3.1HIGH 7.2
- TI-2024-19264 WordPress AI Engine plugin <= 2.1.4 - Server Side Request Forgery (SSRF) vulnerability CVSS 3.1MEDIUM 6.8
- TI-2024-06230 AI Engine < 2.4.8 - Admin+ SQLi CVSS 3.1MEDIUM 4.7
- TI-2024-22775 WordPress AI Engine plugin <= 2.2.63 - Auth. Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.1
- TI-2024-19274 WordPress AI Engine plugin <= 2.1.4 - Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-10499 · CVE Program
- CVE-2024-10499 · NVD
- FIRST EPSS
- GHSA-5w62-ppvg-pwpq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences