Read the docs
TI-2024-09859 Aliases CVE-2024-10638GHSA-gqcv-v7gm-vw94

Product Labels For Woocommerce < 1.5.11 - Admin+ SQLi

Priority MEDIUM 52CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.

Summary

The Product Labels For Woocommerce (Sale Badges) WordPress plugin before 1.5.11 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00417 36th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Product Labels For Woocommerce (Sale Badges) (Unknown): 1.5.11

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownProduct Labels For Woocommerce (Sale Badges)before 1.5.111.5.11Patch availableCNA
  • Product Labels For Woocommerce (Sale Badges) VendorUnknown Affected before 1.5.11 Fixed in 1.5.11 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:acowebs:product_labels_for_woocommerce_\(sale_badges\):*:*:*:*:*:wordpress:*:*before 1.5.11Vulnerableacowebs
  • cpe:2.3:a:acowebs:product_labels_for_woocommerce_\(sale_badges\):*:*:*:*:*:wordpress:*:* Versions before 1.5.11 Vulnerable ·acowebs

Remediation

  • Fix · CNA Product Labels For Woocommerce (Sale Badges) (Unknown) Fixed in 1.5.11

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-10638
  2. 2026-10-03 Alias added: GHSA-gqcv-v7gm-vw94

References

  • TI-2024-11231 Product Labels For Woocommerce < 1.5.9 - Admin+ SQLi CVSS 3.1MEDIUM 4.1
  • TI-2024-16400 WordPress Product Labels For Woocommerce Plugin <= 1.5.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources