Pega Platform versions 8.1 to Infinity 24.2.0 are affected by an XSS issue with search.
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Pega Platform versions 8.1 to Infinity 24.2.0 are affected by an XSS issue with search.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00215 11th percentileScored 2026-11-07
Fix Fixed Pega Infinity (Pegasystems): 24.2.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pegasystems | Pega Infinity | 8.1 to before 24.2.1 | 24.2.1 | Patch available | CNA |
- Pega Infinity VendorPegasystems Affected 8.1 to before 24.2.1 Fixed in 24.2.1 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pega:infinity:*:*:*:*:*:*:*:* | 8.1 – 8.8.5; 23.1 to before 23.1.4; 24.1 to before 24.1.2 | Vulnerable | Pegasystems |
| cpe:2.3:a:pega:infinity:24.2:*:*:*:*:*:*:* | 24.2 | Vulnerable | Pegasystems |
- cpe:2.3:a:pega:infinity:*:*:*:*:*:*:*:* Versions 8.1 – 8.8.5; 23.1 to before 23.1.4; 24.1 to before 24.1.2 Vulnerable ·Pegasystems
- cpe:2.3:a:pega:infinity:24.2:*:*:*:*:*:*:* Versions 24.2 Vulnerable ·Pegasystems
Remediation
- Fix · CNA Pega Infinity (Pegasystems) Fixed in 24.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10716
- 2026-10-03 Alias added: GHSA-c57h-9ch8-w8cv
References
More Pegasystems Infinity vulnerabilities
- TI-2021-09101 Improper authentication in Pegasystems Pega Infinity CVSS 3.1CRITICAL 9.8
- TI-2022-08033 Deserialization of untrusted data in Pegasystems Pega Infinity CVSS 3.1CRITICAL 9.8
- TI-2022-08034 Password authentication bypass vulnerability for local accounts can be used to bypass local authentication checks. CVSS 3.1CRITICAL 9.8
- TI-2024-09357 Pega Platform versions 6.x to Infinity 24.1.1 are affected by an issue with Improper Control of Generation of Code CVSS 3.1CRITICAL 9.8
- TI-2021-09103 Forgotten password reset functionality for local accounts can be used to bypass local authentication checks. CVSS 3.1HIGH 7.8
- TI-2021-09102 Improper access control in Pega Infinity CVSS 3.1MEDIUM 6.6
Sources
- CVE-2024-10716 · CVE Program
- CVE-2024-10716 · NVD
- FIRST EPSS
- GHSA-c57h-9ch8-w8cv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences