WP User Profile Avatar <= 1.0.5 - Cross-Site Request Forgery to Settings Update
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The WP User Profile Avatar plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.5. This is due to missing or incorrect nonce validation on the wpupa_user_admin() function. This makes it possible for unauthenticated attackers to update the plugins setting which controls access to the functionality via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WP Event Manager | WP User Profile Avatar | up to 1.0.5 | — | No fix listed | CNA |
- WP User Profile Avatar VendorWP Event Manager Affected up to 1.0.5 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10789
- 2026-10-03 Alias added: GHSA-75xp-67gh-j85r
References
More WP Event Manager vulnerabilities
- TI-2023-05860 WP User Profile Avatar < 1.0.1 - Author+ Avatar Deletion/Update via IDOR CVSS 3.1MEDIUM 4.3
- TI-2025-30495 WordPress WP Event Manager plugin <= 3.1.51 - Local File Inclusion Vulnerability CVSS 3.1HIGH 8.1
- TI-2025-02444 WP Event Manager <= 3.1.50 - Unauthenticated Stored Cross-Site Scripting via 'organizer_name' CVSS 3.1HIGH 7.2
- TI-2021-06544 Event Banner <= 1.3 - Arbitrary File Upload to RCE CVSS 3.1HIGH 7.2
- TI-2023-25834 WordPress WP Event Manager Plugin <= 3.1.39 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2025-23322 WordPress WP Event Manager plugin <= 3.2.0 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-10789 · CVE Program
- CVE-2024-10789 · NVD
- FIRST EPSS
- GHSA-75xp-67gh-j85r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences