Logo Slider < 4.5.0 - Contributor+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-78.
Summary
The Logo Slider WordPress plugin before 4.5.0 does not sanitise and escape some of its Logo and Slider settings, which could allow high privilege users such as Contributor to perform Stored Cross-Site Scripting
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Logo Slider | before 4.5.0 | 4.5.0 | Patch available | CNA |
- Logo Slider VendorUnknown Affected before 4.5.0 Fixed in 4.5.0 Patch available CNA
Remediation
- Fix · CNA Logo Slider (Unknown) Fixed in 4.5.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Logo Slider 4.5.0
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2024-09701 Logo Slider < 4.5.0 - Author+ Stored XSSPriority MEDIUM 58
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10896
- 2026-10-03 Alias added: GHSA-x8c4-4qx3-cf7m
References
More logichunt Logo Slider vulnerabilities
- TI-2024-05045 Logo Slider < 4.1.0 - Contributor+ Stored XSS CVSS 3.1HIGH 7.6
- TI-2024-11418 Logo Slider < 4.6.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-09701 Logo Slider < 4.5.0 - Author+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2022-04262 Logo Slider < 3.6.0 - Contributor+ Stored XSS in Shortcode CVSS 3.1MEDIUM 5.4
- TI-2024-03083 Logo Slider < 4.0.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-10896 · CVE Program
- CVE-2024-10896 · NVD
- FIRST EPSS
- GHSA-x8c4-4qx3-cf7m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences