Image Widget < 4.4.11 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Image Widget WordPress plugin before 4.4.11 does not sanitise and escape some of its Image Widget settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00332 26th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Image Widget (Unknown): 4.4.11
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Image Widget | before 4.4.11 | 4.4.11 | Patch available | CNA |
- Image Widget VendorUnknown Affected before 4.4.11 Fixed in 4.4.11 Patch available CNA
Remediation
- Fix · CNA Image Widget (Unknown) Fixed in 4.4.11
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10939
- 2026-10-03 Alias added: GHSA-vvvx-g9vg-6c4g
References
Sources
- CVE-2024-10939 · CVE Program
- CVE-2024-10939 · NVD
- FIRST EPSS
- GHSA-vvvx-g9vg-6c4g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences