Single byte overread with convert.quoted-printable-decode filter
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, due to an error in convert.quoted-printable-decode filter certain data can lead to buffer overread by one byte, which can in certain circumstances lead to crashes or disclose content of other memory areas.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA PHP (PHP Group) Fixed in 8.1.31, 8.2.26, 8.3.14
Red Hat 5 advisories
- RHSA-2026:2470 Released 2026-02-10 · Red Hat rating Moderatephp:7.4 security update
- Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.18-1.module+el8.10.0+22485+a3539972.noarch::php:7.4, libzip-1.6.1-1.module+el8.10.0+22485+a3539972.aarch64::php:7.4, libzip-1.6.1-1.module+el8.10.0+22485+a3539972.ppc64le::php:7.4 +47
- RHSA-2025:15687 Released 2025-09-11 · Red Hat rating Moderatephp:8.2 security update
- Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.23-1.module+el8.10.0+20770+a5eca186.noarch::php:8.2, libzip-1.7.3-1.module+el8.10.0+20770+a5eca186.aarch64::php:8.2, libzip-1.7.3-1.module+el8.10.0+20770+a5eca186.ppc64le::php:8.2 +47
- RHSA-2025:7432 Released 2025-05-13 · Red Hat rating Moderatephp:8.2 security update
- Red Hat Enterprise Linux AppStream (v. 9) apcu-panel-5.1.23-1.module+el9.4.0+20748+b46899d2.noarch::php:8.2, php-8.2.28-1.module+el9.6.0+23063+43495379.aarch64::php:8.2, php-8.2.28-1.module+el9.6.0+23063+43495379.ppc64le::php:8.2 +47
Show 2 more Red Hat advisories
- RHSA-2025:7315 Released 2025-05-13 · Red Hat rating Moderatephp security update
- Red Hat Enterprise Linux AppStream (v. 9) php-8.0.30-2.el9, php-bcmath-8.0.30-2.el9, php-cli-8.0.30-2.el9 +22
- RHSA-2025:4263 Released 2025-04-28 · Red Hat rating Moderatephp:8.1 security update
- Red Hat Enterprise Linux AppStream (v. 9) apcu-panel-5.1.21-1.module+el9.1.0.z+15477+cb86791d.noarch::php:8.1, php-8.1.32-1.module+el9.5.0+23047+aadb97d2.aarch64::php:8.1, php-8.1.32-1.module+el9.5.0+23047+aadb97d2.ppc64le::php:8.1 +47
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
PHP 8.1.31, 8.2.26, 8.3.14
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2024-10409 Integer overflow in the firebird and dblib quoters causing OOB writesPriority MEDIUM 53
- TI-2024-10407 Configuring a proxy in a stream context might allow for CRLF injection in URIsPriority LOW 34
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2025:15687, RHSA-2026:2470 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:4263, RHSA-2025:7315, RHSA-2025:7432 |
Not affected: 2 products
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-11233
References
More PHP Group vulnerabilities
- TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
- TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
- TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
- TI-2024-01743 Command injection via array-ish $command parameter of proc_open() CVSS 3.1CRITICAL 9.4
- TI-2022-13555 PDO::quote() may return unquoted string CVSS 3.1CRITICAL 9.1
- TI-2024-10408 Reference counting in php_request_shutdown causes Use-After-Free CVSS 4.0CRITICAL 9.2
Sources
- CVE-2024-11233 · CVE Program
- CVE-2024-11233 · NVD
- FIRST EPSS
- CVE-2024-11233 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences