Read the docs
TI-2024-10991 Aliases CVE-2024-11848GHSA-phj2-ppc2-2mjf

NitroPack <= 1.17.0 - Missing Authorization to Authenticated (Subscriber+) Limited Options Update

Priority LOW 36CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The NitroPack plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'nitropack_dismiss_notice_forever' AJAX action in all versions up to, and including, 1.17.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to update arbitrary options to a fixed value of '1' which can activate certain options (e.g., enable user registration) or modify certain options in a way that leads to a denial of service condition.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00699 53rd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
nitropackNitroPack – Performance, Page Speed & Cache Plugin for Core Web Vitals, CDN & Image Optimizationup to 1.17.0—No fix listedCNA
  • NitroPack – Performance, Page Speed & Cache Plugin for Core Web Vitals, CDN & Image Optimization Vendornitropack Affected up to 1.17.0 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-11848
  2. 2026-10-03 Alias added: GHSA-phj2-ppc2-2mjf

References

  • TI-2024-29511 WordPress NitroPack plugin <= 1.16.7 - Unauthenticated Arbitrary Shortcode Execution vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2023-28560 WordPress NitroPack Plugin <= 1.10.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2026-28638 WordPress NitroPack plugin <= 1.19.3 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2025-08030 Missing authorization in NitroPack – Performance, Page Speed & Cache Plugin for Core Web… CVSS 3.1MEDIUM 4.3
  • TI-2024-10994 NitroPack <= 1.17.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Transient Update CVSS 3.1MEDIUM 4.3

Sources