Read the docs
TI-2025-08030 Aliases CVE-2025-8778GHSA-82p6-2j9g-whvj

Missing authorization in NitroPack – Performance, Page Speed & Cache Plugin for Core Web…

Priority LOW 20CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The NitroPack plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the nitropack_set_compression_ajax() function in all versions up to, and including, 1.18.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update the nitropack-enableCompression option and effectively change plugin compression settings.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00248 16th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
nitropackNitroPack – Performance, Page Speed & Cache Plugin for Core Web Vitals, CDN & Image Optimizationup to 1.18.4—No fix listedCNA
  • NitroPack – Performance, Page Speed & Cache Plugin for Core Web Vitals, CDN & Image Optimization Vendornitropack Affected up to 1.18.4 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-8778
  2. 2026-10-03 Alias added: GHSA-82p6-2j9g-whvj

References

  • TI-2024-29511 WordPress NitroPack plugin <= 1.16.7 - Unauthenticated Arbitrary Shortcode Execution vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2023-28560 WordPress NitroPack Plugin <= 1.10.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2024-10991 NitroPack <= 1.17.0 - Missing Authorization to Authenticated (Subscriber+) Limited Options Update CVSS 3.1HIGH 8.1
  • TI-2026-28638 WordPress NitroPack plugin <= 1.19.3 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2024-10994 NitroPack <= 1.17.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Transient Update CVSS 3.1MEDIUM 4.3

Sources