Apus Framework <= 2.4 - Authenticated (Subscriber+) Arbitrary Options Update in import_page_options
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Apus Framework plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the 'import_page_options' function in all versions up to, and including, 2.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site. NOTE: This vulnerability was partially fixed in version 2.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ApusTheme | Apus Framework | up to 2.4 | — | No fix listed | CNA |
- Apus Framework VendorApusTheme Affected up to 2.4 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apusthemes:superio:*:*:*:*:*:wordpress:*:* | up to 2.3 | Vulnerable | ApusThemes |
- cpe:2.3:a:apusthemes:superio:*:*:*:*:*:wordpress:*:* Versions up to 2.3 Vulnerable ·ApusThemes
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12296
- 2026-10-03 Alias added: GHSA-4vxh-jq3c-5rhw
References
More ApusTheme vulnerabilities
- TI-2025-10568 WP Freeio <= 1.2.21 - Unauthenticated Privilege Escalation CVSS 3.1CRITICAL 9.8
- TI-2025-12580 WP CarDealer <= 1.2.16 - Unauthenticated Privilege Escalation CVSS 3.1CRITICAL 9.8
- TI-2026-41607 WordPress ApusListing theme <= 1.2.63 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2025-36055 WordPress Findgo Theme <= 1.3.55 - Cross Site Request Forgery (CSRF) Vulnerability CVSS 3.1HIGH 8.8
- TI-2025-23386 WordPress Yozi theme <= 2.0.63 - Local File Inclusion Vulnerability CVSS 3.1HIGH 8.1
- TI-2025-23383 WordPress Butcher theme <= 2.40 - Local File Inclusion Vulnerability CVSS 3.1HIGH 8.1
Sources
- CVE-2024-12296 · CVE Program
- CVE-2024-12296 · NVD
- FIRST EPSS
- GHSA-4vxh-jq3c-5rhw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences