WPC Shop as a Customer for WooCommerce <= 1.2.8 - Authentication Bypass Due to Insufficiently Unique Key
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The WPC Shop as a Customer for WooCommerce plugin for WordPress is vulnerable to account takeover and privilege escalation in all versions up to, and including, 1.2.8. This is due to the 'generate_key' function not producing a sufficiently random value. This makes it possible for authenticated attackers, with Subscriber-level access and above, to log in as site administrators, granted they have triggered the ajax_login() function which generates a unique key that can be used to log in.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12432
- 2026-10-03 Alias added: GHSA-hhr2-4cvp-f289
References
More wpclever vulnerabilities
- TI-2024-33849 WordPress WPC Shop as a Customer for WooCommerce plugin <= 1.2.6 - PHP Object Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2025-22095 WordPress WPC Smart Linked Products plugin <= 1.3.5 - Privilege Escalation vulnerability CVSS 3.1HIGH 8.8
- TI-2025-22042 Missing authorization in wpclever WPC Smart Upsell Funnel for WooCommerce CVSS 3.1HIGH 8.8
- TI-2024-09664 WPC Smart Messages for WooCommerce <= 4.2.1 - Authenticated (Subscriber+) Local File Inclusion CVSS 3.1HIGH 8.8
- TI-2026-63681 Improper privilege management in wpclever WPC Shop as a Customer for WooCommerce CVSS 3.1HIGH 8.8
- TI-2025-03002 WPC Admin Columns 2.0.6 - 2.1.0 - Authenticated (Subscriber+) Privilege Escalation via User Meta Update CVSS 3.1HIGH 8.8
Sources
- CVE-2024-12432 · CVE Program
- CVE-2024-12432 · NVD
- FIRST EPSS
- GHSA-hhr2-4cvp-f289 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences