Elasticsearch Incorrect Authorization
Priority LOW 27CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
An issue was discovered where improper authorization controls affected certain queries that could allow a malicious actor to circumvent Document Level Security in Elasticsearch and get access to documents that their roles would normally not allow.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0046 40th percentileScored 2026-11-07
Fix Fixed org.elasticsearch:elasticsearch (Maven): 8.16.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Elasticsearch | 8.16.0 – 8.16.1 | — | No fix listed | CNA |
| — | org.elasticsearch:elasticsearch (Maven) | 8.16.0 to before 8.16.2 | 8.16.2 | Patch available | GHSA-5mpw-4546-2wcr |
- Elasticsearch VendorElastic Affected 8.16.0 – 8.16.1 Fixed in — No fix listed CNA
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected 8.16.0 to before 8.16.2 Fixed in 8.16.2 Patch available GHSA-5mpw-4546-2wcr
Remediation
- Fix · GHSA-5mpw-4546-2wcr org.elasticsearch:elasticsearch (Maven) Fixed in 8.16.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- Logging Subsystem for Red Hat OpenShift
- Red Hat Quay 3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12539
- 2026-10-03 Alias added: GHSA-5mpw-4546-2wcr
References
More Elasticsearch vulnerabilities
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
- TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
- TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-12539 · CVE Program
- CVE-2024-12539 · NVD
- FIRST EPSS
- GHSA-5mpw-4546-2wcr · GitHub Advisory Database · CC BY 4.0
- CVE-2024-12539 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences