Read the docs
TI-2024-11677 Aliases CVE-2024-12585GHSA-p52h-3642-m4x3

PropertyHive < 2.1.1 - Reflected XSS

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Property Hive WordPress plugin before 2.1.1 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00633 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Property Hive (Unknown): 2.1.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownProperty Hivebefore 2.1.12.1.1Patch availableCNA
  • Property Hive VendorUnknown Affected before 2.1.1 Fixed in 2.1.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wp-property-hive:propertyhive:*:*:*:*:*:wordpress:*:*before 2.1.1VulnerablePropertyHive
  • cpe:2.3:a:wp-property-hive:propertyhive:*:*:*:*:*:wordpress:*:* Versions before 2.1.1 Vulnerable ·PropertyHive

Remediation

  • Fix · CNA Property Hive (Unknown) Fixed in 2.1.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-12585
  2. 2026-10-03 Alias added: GHSA-p52h-3642-m4x3
  3. 2026-10-25 EPSS moved to the 50th–90th percentile

References

  • TI-2024-19690 WordPress PropertyHive plugin <= 2.0.8 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-15554 WordPress PropertyHive Plugin <= 2.0.5 is vulnerable to PHP Object Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-18586 WordPress PropertyHive plugin <= 2.0.9 - PHP Object Injection vulnerability CVSS 3.1HIGH 8.8
  • TI-2024-07872 PropertyHive <= 2.0.19 - Cross-Site Request Forgery via save_account_details CVSS 3.1HIGH 8.8
  • TI-2023-13603 WordPress PropertyHive Plugin <= 1.5.46 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2023-08881 WordPress PropertyHive Plugin <= 1.5.48 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
See all 12 →

Sources