MailPoet < 5.5.2 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The MailPoet WordPress plugin before 5.5.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00355 29th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed MailPoet (Unknown): 5.5.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | MailPoet | before 5.5.2 | 5.5.2 | Patch available | CNA |
- MailPoet VendorUnknown Affected before 5.5.2 Fixed in 5.5.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:automattic:mailpoet:*:*:*:*:free:wordpress:*:* | before 5.5.2 | Vulnerable | Automattic |
- cpe:2.3:a:automattic:mailpoet:*:*:*:*:free:wordpress:*:* Versions before 5.5.2 Vulnerable ·Automattic
Remediation
- Fix · CNA MailPoet (Unknown) Fixed in 5.5.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12743
- 2026-10-03 Alias added: GHSA-9fcp-xcwr-cjm9
References
More Automattic Mailpoet vulnerabilities
- TI-2024-09365 MailPoet < 5.3.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2019-08879 The MailPoet plugin before 3.23.2 for WordPress allows remote attackers to inject… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-12743 · CVE Program
- CVE-2024-12743 · NVD
- FIRST EPSS
- GHSA-9fcp-xcwr-cjm9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences