Read the docs
TI-2024-12171 Aliases CVE-2024-13123GHSA-6qrv-h235-q5x7

AFI < 1.100.0 - Admin+ Stored XSS

Priority MEDIUM 50CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The AFI WordPress plugin before 1.100.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00267 18th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed AFI (Unknown): 1.100.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAFIbefore 1.100.01.100.0Patch availableCNA
  • AFI VendorUnknown Affected before 1.100.0 Fixed in 1.100.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:advancedformintegration:advanced_form_integration:*:*:*:*:*:wordpress:*:*before 1.100.0Vulnerablenasirahmed
  • cpe:2.3:a:advancedformintegration:advanced_form_integration:*:*:*:*:*:wordpress:*:* Versions before 1.100.0 Vulnerable ·nasirahmed

Remediation

  • Fix · CNA AFI (Unknown) Fixed in 1.100.0

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    AFI 1.100.0

    2 records Highest priority Priority MEDIUM 2 MEDIUM

    Other records, highest priority first

    • TI-2024-12170 AFI < 1.100.0 - Admin+ Stored XSSPriority MEDIUM 50

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-13123
  2. 2026-10-03 Alias added: GHSA-6qrv-h235-q5x7

References

  • TI-2024-12170 AFI < 1.100.0 - Admin+ Stored XSS CVSS 3.1LOW 3.5
  • TI-2023-27758 SQL injection in nasirahmed Advanced Form Integration – Connect WooCommerce and Contact… CVSS 3.1HIGH 7.6
  • TI-2024-10083 AFI – The Easiest Integration Plugin <= 1.92.0 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2022-23377 Cross-site scripting in nasirahmed Connect Contact Form 7, WooCommerce To Google Sheets &… CVSS 3.1MEDIUM 5.9
  • TI-2024-28992 WordPress AFI – The Easiest Integration Plugin plugin <= 1.89.4 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1MEDIUM 4.3

Sources