Path traversal in WP Experts File Manager Advanced Shortcode
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The File Manager Advanced Shortcode plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 2.5.4 (file-manager-advanced-shortcode) and 2.5.6 (advanced-file-manager-pro-premium), via the 'file_manager_advanced' shortcode. This makes it possible for authenticated attackers, with Administrator-level access and above, to include and execute arbitrary JavaScript files on the server. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included. Sites currently using 2.5.4 (file-manager-advanced-shortcode) should be updated to 2.6.0 (advanced-file-manager-pro-premium).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WP Experts | File Manager Advanced Shortcode | up to 2.5.4 | — | No fix listed | CNA |
| WP Experts | File Manager Advanced Shortcode | up to 2.5.6 | — | No fix listed | CNA |
- File Manager Advanced Shortcode VendorWP Experts Affected up to 2.5.4 Fixed in — No fix listed CNA
- File Manager Advanced Shortcode VendorWP Experts Affected up to 2.5.6 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13914
- 2026-10-03 Alias added: GHSA-7chh-jrvc-3cqw
References
More WP Experts vulnerabilities
- TI-2023-02941 Protect WP Admin < 4.0 - Unauthenticated Protection Bypass CVSS 3.1MEDIUM 6.1
- TI-2021-07186 Protect WP Admin < 3.6.2 - Unauthenticated Plugin Deactivation CVSS 3.1HIGH 7.5
- TI-2023-14926 WordPress WP Categories Widget Plugin <= 2.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2022-01583 Custom Share Buttons with Floating Sidebar < 4.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2022-00779 WP Social Buttons <= 2.1 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2024-13914 · CVE Program
- CVE-2024-13914 · NVD
- FIRST EPSS
- GHSA-7chh-jrvc-3cqw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences