Command injection in data collector backup due to insufficient patching of CVE-2023-38208
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Adobe Commerce versions 2.4.6-p3, 2.4.5-p5, 2.4.4-p6 and earlier are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead in arbitrary code execution by an attacker. Exploitation of this issue does not require user interaction.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Adobe Commerce | up to 2.4.4-p6 | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-525f-pvj5-vqmq |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-525f-pvj5-vqmq |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-525f-pvj5-vqmq |
| — | magento/community-edition (Packagist) | 2.4.6-p1 to before 2.4.6-p4 | 2.4.6-p4 | Patch available | GHSA-525f-pvj5-vqmq |
| — | magento/community-edition (Packagist) | 2.4.5-p1 to before 2.4.5-p6 | 2.4.5-p6 | Patch available | GHSA-525f-pvj5-vqmq |
| — | magento/community-edition (Packagist) | 2.4.4-p1 to before 2.4.4-p7 | 2.4.4-p7 | Patch available | GHSA-525f-pvj5-vqmq |
| — | magento/project-community-edition (Packagist) | up to 2.0.2 | — | No fix listed | GHSA-525f-pvj5-vqmq |
- Adobe Commerce VendorAdobe Affected up to 2.4.4-p6 Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-525f-pvj5-vqmq
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-525f-pvj5-vqmq
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-525f-pvj5-vqmq
- magento/community-edition (Packagist) Vendor— Affected 2.4.6-p1 to before 2.4.6-p4 Fixed in 2.4.6-p4 Patch available GHSA-525f-pvj5-vqmq
- magento/community-edition (Packagist) Vendor— Affected 2.4.5-p1 to before 2.4.5-p6 Fixed in 2.4.5-p6 Patch available GHSA-525f-pvj5-vqmq
- magento/community-edition (Packagist) Vendor— Affected 2.4.4-p1 to before 2.4.4-p7 Fixed in 2.4.4-p7 Patch available GHSA-525f-pvj5-vqmq
- magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-525f-pvj5-vqmq
CPE configurations NVD · 17
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:* | 2.4.4 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p1:*:*:*:*:*:* | 2.4.4 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p2:*:*:*:*:*:* | 2.4.4 p2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p3:*:*:*:*:*:* | 2.4.4 p3 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p4:*:*:*:*:*:* | 2.4.4 p4 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p5:*:*:*:*:*:* | 2.4.4 p5 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p6:*:*:*:*:*:* | 2.4.4 p6 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.5:-:*:*:*:*:*:* | 2.4.5 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.5:p1:*:*:*:*:*:* | 2.4.5 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.5:p2:*:*:*:*:*:* | 2.4.5 p2 | Vulnerable | Adobe |
- cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p1:*:*:*:*:*:* Versions 2.4.4 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p2:*:*:*:*:*:* Versions 2.4.4 p2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p3:*:*:*:*:*:* Versions 2.4.4 p3 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p4:*:*:*:*:*:* Versions 2.4.4 p4 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p5:*:*:*:*:*:* Versions 2.4.4 p5 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p6:*:*:*:*:*:* Versions 2.4.4 p6 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.5:-:*:*:*:*:*:* Versions 2.4.5 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.5:p1:*:*:*:*:*:* Versions 2.4.5 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.5:p2:*:*:*:*:*:* Versions 2.4.5 p2 Vulnerable ·Adobe
Show 7 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adobe:commerce:2.4.5:p3:*:*:*:*:*:* | 2.4.5 p3 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.5:p4:*:*:*:*:*:* | 2.4.5 p4 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.5:p5:*:*:*:*:*:* | 2.4.5 p5 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.6:-:*:*:*:*:*:* | 2.4.6 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.6:p1:*:*:*:*:*:* | 2.4.6 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.6:p2:*:*:*:*:*:* | 2.4.6 p2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.6:p3:*:*:*:*:*:* | 2.4.6 p3 | Vulnerable | Adobe |
- cpe:2.3:a:adobe:commerce:2.4.5:p3:*:*:*:*:*:* Versions 2.4.5 p3 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.5:p4:*:*:*:*:*:* Versions 2.4.5 p4 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.5:p5:*:*:*:*:*:* Versions 2.4.5 p5 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.6:-:*:*:*:*:*:* Versions 2.4.6 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.6:p1:*:*:*:*:*:* Versions 2.4.6 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.6:p2:*:*:*:*:*:* Versions 2.4.6 p2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.6:p3:*:*:*:*:*:* Versions 2.4.6 p3 Vulnerable ·Adobe
Remediation
- Fix · GHSA-525f-pvj5-vqmq magento/community-edition (Packagist) Fixed in 2.4.6-p4 Advisory →
- Fix · GHSA-525f-pvj5-vqmq magento/community-edition (Packagist) Fixed in 2.4.5-p6 Advisory →
- Fix · GHSA-525f-pvj5-vqmq magento/community-edition (Packagist) Fixed in 2.4.4-p7 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Adobe Commerce — helpx.adobe.com/security/products/magento/apsb24-03.html
5 records Highest priority Priority MEDIUM 2 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2024-13523 [Adobe Commerce] Stored XSS from low privileged admin user on every admin page, bypassing CVE-2023-29297Priority MEDIUM 44
- TI-2024-13522 [Spain] CSRF to delete Requisition Lists at Adobe CommercePriority LOW 32
- TI-2024-13521 Stored admin XSS via PayPal authentication certificatePriority LOW 25
Timeline
- 2026-10-02 Threatist record created from CVE-2024-20720
- 2026-10-03 Alias added: GHSA-525f-pvj5-vqmq
References
More Adobe Commerce vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2022-08035 Adobe Commerce checkout improper input validation leads to remote code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2026-35762 Unrestricted file upload in Adobe Commerce allows code execution KEVCVSS 3.1CRITICAL 9.3
- TI-2026-50010 Adobe Commerce | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 9.1
- TI-2025-34067 Adobe Commerce | Improper Input Validation (CWE-20) KEVCVSS 3.1CRITICAL 9.1
Sources
- CVE-2024-20720 · CVE Program
- CVE-2024-20720 · NVD
- FIRST EPSS
- GHSA-525f-pvj5-vqmq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences