Integer overflow in QNAP QTS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
An integer overflow or wraparound vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow users to compromise the security of the system via a network. We have already fixed the vulnerability in the following versions: QTS 5.1.3.2578 build 20231110 and later QuTS hero h5.1.3.2578 build 20231110 and later QuTScloud c5.1.5.2651 and later
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| QNAP | QTS | 5.1.x to before 5.1.3.2578 build 20231110 | 5.1.3.2578 build 20231110 | Patch available | CNA |
| QNAP | QuTS hero | h5.1.x to before h5.1.3.2578 build 20231110 | h5.1.3.2578 build 20231110 | Patch available | CNA |
| QNAP | QuTScloud | c5.x.x to before c5.1.5.2651 | c5.1.5.2651 | Patch available | CNA |
- QTS VendorQNAP Affected 5.1.x to before 5.1.3.2578 build 20231110 Fixed in 5.1.3.2578 build 20231110 Patch available CNA
- QuTS hero VendorQNAP Affected h5.1.x to before h5.1.3.2578 build 20231110 Fixed in h5.1.3.2578 build 20231110 Patch available CNA
- QuTScloud VendorQNAP Affected c5.x.x to before c5.1.5.2651 Fixed in c5.1.5.2651 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:qnap:qts:*:*:*:*:*:*:*:* | 5.0.0 to before 5.1.3.2578 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:qts:5.1.3.2578:-:*:*:*:*:*:* | 5.1.3.2578 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:quts_hero:*:*:*:*:*:*:*:* | h5.0.0 to before h5.1.3.2578 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:quts_hero:h5.1.3.2578:-:*:*:*:*:*:* | h5.1.3.2578 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:qutscloud:*:*:*:*:*:*:*:* | c5.0.0.1919 to before c5.1.5.2651 | Vulnerable | QNAP |
- cpe:2.3:o:qnap:qts:*:*:*:*:*:*:*:* Versions 5.0.0 to before 5.1.3.2578 Vulnerable ·QNAP
- cpe:2.3:o:qnap:qts:5.1.3.2578:-:*:*:*:*:*:* Versions 5.1.3.2578 Vulnerable ·QNAP
- cpe:2.3:o:qnap:quts_hero:*:*:*:*:*:*:*:* Versions h5.0.0 to before h5.1.3.2578 Vulnerable ·QNAP
- cpe:2.3:o:qnap:quts_hero:h5.1.3.2578:-:*:*:*:*:*:* Versions h5.1.3.2578 Vulnerable ·QNAP
- cpe:2.3:o:qnap:qutscloud:*:*:*:*:*:*:*:* Versions c5.0.0.1919 to before c5.1.5.2651 Vulnerable ·QNAP
Remediation
- Fix · CNA QTS (QNAP Systems Inc.) Fixed in 5.1.3.2578 build 20231110
- Fix · CNA QuTS hero (QNAP Systems Inc.) Fixed in h5.1.3.2578 build 20231110
- Fix · CNA QuTScloud (QNAP Systems Inc.) Fixed in c5.1.5.2651
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
QNAP Systems QuTScloud c5.1.5.2651
5 records Highest priority Priority HIGH 1 HIGH, 2 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2023-28022 Path traversal in QNAP QTSPriority HIGH 65
- TI-2023-28023 Path traversal in QNAP QTSPriority MEDIUM 63
- TI-2024-21640 Command injection in QNAP QTSPriority MEDIUM 53
Timeline
- 2026-10-02 Threatist record created from CVE-2024-21905
- 2026-10-03 Alias added: GHSA-22fc-mghg-jrwm
References
More QNAP Qts vulnerabilities
- TI-2020-02221 Command Injection Vulnerability in QTS and QuTS hero KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05101 Improper input validation in QNAP NAS devices KEVCVSS 3.1CRITICAL 9.8
- TI-2018-14137 Improper input validation in QNAP QTS KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-14131 Cross-site scripting in QNAP QTS KEVCVSS 3.1HIGH 8.0
Sources
- CVE-2024-21905 · CVE Program
- CVE-2024-21905 · NVD
- FIRST EPSS
- GHSA-22fc-mghg-jrwm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences