A vulnerability has been identified in Node.js, affecting users of the experimental…
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.0 · CNA. Fix status from CNA and Red Hat.
Summary
A vulnerability has been identified in Node.js, affecting users of the experimental permission model when the --allow-fs-read flag is used. This flaw arises from an inadequate permission model that fails to restrict file stats through the fs.lstat API. As a result, malicious actors can retrieve stats from files that they do not have explicit read access to. This vulnerability affects all users using the experimental permission model in Node.js 20 and Node.js 21. Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | Node | 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 19.0 and later; 20.0 to before 20.15.1; 21.0 and later; 22.0 to before 22.4.1 | 20.15.1, 22.4.1 | Patch available | CNA |
- Node VendorNodeJS Affected 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 19.0 and later; 20.0 to before 20.15.1; 21.0 and later; 22.0 to before 22.4.1 Fixed in 20.15.1, 22.4.1 Patch available CNA
Remediation
- Fix · CNA Node (NodeJS) Fixed in 20.15.1, 22.4.1
Red Hat 2 advisories
- RHSA-2024:5814 Released 2024-08-26 · Red Hat rating Moderatenodejs:20 security update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:20.16.0-1.module+el8.10.0+22203+a88c8310.aarch64::nodejs:20, nodejs-1:20.16.0-1.module+el8.10.0+22203+a88c8310.ppc64le::nodejs:20, nodejs-1:20.16.0-1.module+el8.10.0+22203+a88c8310.s390x::nodejs:20 +20
- RHSA-2024:5815 Released 2024-08-26 · Red Hat rating Moderatenodejs:20 security update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:20.16.0-1.module+el9.4.0+22197+9e60f127.aarch64::nodejs:20, nodejs-1:20.16.0-1.module+el9.4.0+22197+9e60f127.ppc64le::nodejs:20, nodejs-1:20.16.0-1.module+el9.4.0+22197+9e60f127.s390x::nodejs:20 +20
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2024:5814 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2024:5815 |
Not affected: 2 products
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22018
- 2026-10-03 Alias added: GHSA-9xvm-xmw3-2hm2
References
More NodeJS vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18584 Race condition in NodeJS Node CVSS 3.0HIGH 8.2
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2024-22018 · CVE Program
- CVE-2024-22018 · NVD
- FIRST EPSS
- GHSA-9xvm-xmw3-2hm2 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-22018 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences