Code injection in NodeJS Node
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · High · High
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.0 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-94.
Summary
A security flaw in Node.js allows a bypass of network import restrictions. By embedding non-network imports in data URLs, an attacker can execute arbitrary code, compromising system security. Verified on various platforms, the vulnerability is mitigated by forbidding data URLs in network imports. Exploiting this flaw can violate network import security, posing a risk to developers and servers.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | Node | 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.20.4; 19.0 and later; 20.0 to before 20.15.1; 21.0 and later; 22.0 to before 22.4.1 | 18.20.4, 20.15.1, 22.4.1 | Patch available | CNA |
- Node VendorNodeJS Affected 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.20.4; 19.0 and later; 20.0 to before 20.15.1; 21.0 and later; 22.0 to before 22.4.1 Fixed in 18.20.4, 20.15.1, 22.4.1 Patch available CNA
Remediation
- Fix · CNA Node (NodeJS) Fixed in 18.20.4, 20.15.1, 22.4.1
Red Hat 4 advisories
- RHSA-2024:6148 Released 2024-09-03 · Red Hat rating Moderatenodejs:18 security update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:18.20.4-1.module+el8.10.0+22199+56ea0ead.aarch64::nodejs:18, nodejs-1:18.20.4-1.module+el8.10.0+22199+56ea0ead.ppc64le::nodejs:18, nodejs-1:18.20.4-1.module+el8.10.0+22199+56ea0ead.s390x::nodejs:18 +20
- RHSA-2024:6147 Released 2024-09-03 · Red Hat rating Moderatenodejs:18 security update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:18.20.4-1.module+el9.4.0+22195+c221878e.aarch64::nodejs:18, nodejs-1:18.20.4-1.module+el9.4.0+22195+c221878e.ppc64le::nodejs:18, nodejs-1:18.20.4-1.module+el9.4.0+22195+c221878e.s390x::nodejs:18 +20
- RHSA-2024:5814 Released 2024-08-26 · Red Hat rating Moderatenodejs:20 security update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:20.16.0-1.module+el8.10.0+22203+a88c8310.aarch64::nodejs:20, nodejs-1:20.16.0-1.module+el8.10.0+22203+a88c8310.ppc64le::nodejs:20, nodejs-1:20.16.0-1.module+el8.10.0+22203+a88c8310.s390x::nodejs:20 +20
Show 1 more Red Hat advisories
- RHSA-2024:5815 Released 2024-08-26 · Red Hat rating Moderatenodejs:20 security update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:20.16.0-1.module+el9.4.0+22197+9e60f127.aarch64::nodejs:20, nodejs-1:20.16.0-1.module+el9.4.0+22197+9e60f127.ppc64le::nodejs:20, nodejs-1:20.16.0-1.module+el9.4.0+22197+9e60f127.s390x::nodejs:20 +20
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2024:5814, RHSA-2024:6148 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2024:5815, RHSA-2024:6147 |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22020
- 2026-10-03 Alias added: GHSA-ch4x-f5c4-36gv
References
More NodeJS vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18584 Race condition in NodeJS Node CVSS 3.0HIGH 8.2
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2024-22020 · CVE Program
- CVE-2024-22020 · NVD
- FIRST EPSS
- GHSA-ch4x-f5c4-36gv · GitHub Advisory Database · CC BY 4.0
- CVE-2024-22020 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences