A vulnerability in Node.js has been identified, allowing for a Denial of Service (DoS)…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 4 fixed, 1 without a fix
Attack profile from CVSS 3.0 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-404.
Summary
A vulnerability in Node.js has been identified, allowing for a Denial of Service (DoS) attack through resource exhaustion when using the fetch() function to retrieve content from an untrusted URL. The vulnerability stems from the fact that the fetch() function in Node.js always decodes Brotli, making it possible for an attacker to cause resource exhaustion when fetching content from an untrusted URL. An attacker controlling the URL passed into fetch() can exploit this vulnerability to exhaust memory, potentially leading to process termination, depending on the system configuration.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | Node | 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.19.1; 19.0 and later; 20.0 to before 20.11.1; 21.0 to before 21.6.2 | 18.19.1, 20.11.1, 21.6.2 | Patch available | CNA |
- Node VendorNodeJS Affected 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 and later; 17.0 and later; 18.0 to before 18.19.1; 19.0 and later; 20.0 to before 20.11.1; 21.0 to before 21.6.2 Fixed in 18.19.1, 20.11.1, 21.6.2 Patch available CNA
Remediation
- Fix · CNA Node (NodeJS) Fixed in 18.19.1, 20.11.1, 21.6.2
Red Hat 7 advisories
- RHSA-2024:4721 Released 2024-07-23 · Red Hat rating Moderatenodejs security update
- Red Hat Enterprise Linux AppStream E4S (v.9.0) nodejs-1:16.20.2-9.el9_0, nodejs-docs-1:16.20.2-9.el9_0, nodejs-full-i18n-1:16.20.2-9.el9_0 +2
- RHSA-2024:4559 Released 2024-07-16 · Red Hat rating Moderatenodejs security update
- Red Hat Enterprise Linux AppStream EUS (v.9.2) nodejs-1:16.20.2-6.el9_2.3, nodejs-docs-1:16.20.2-6.el9_2.3, nodejs-full-i18n-1:16.20.2-6.el9_2.3 +2
- RHSA-2024:2910 Released 2024-05-20 · Red Hat rating Importantnodejs security update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:16.20.2-8.el9_4, nodejs-docs-1:16.20.2-8.el9_4, nodejs-full-i18n-1:16.20.2-8.el9_4 +2
Show 4 more Red Hat advisories
- RHSA-2024:2853 Released 2024-05-15 · Red Hat rating Importantnodejs:20 security update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:20.12.2-2.module+el9.4.0+21731+46b5b8a7.aarch64::nodejs:20, nodejs-1:20.12.2-2.module+el9.4.0+21731+46b5b8a7.ppc64le::nodejs:20, nodejs-1:20.12.2-2.module+el9.4.0+21731+46b5b8a7.s390x::nodejs:20 +20
- RHSA-2024:2780 Released 2024-05-09 · Red Hat rating Importantnodejs:18 security update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:18.20.2-1.module+el8.9.0+21767+537f34ee.aarch64::nodejs:18, nodejs-1:18.20.2-1.module+el8.9.0+21767+537f34ee.ppc64le::nodejs:18, nodejs-1:18.20.2-1.module+el8.9.0+21767+537f34ee.s390x::nodejs:18 +20
- RHSA-2024:2778 Released 2024-05-09 · Red Hat rating Importantnodejs:20 security update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:20.12.2-2.module+el8.9.0+21743+0b3f1be2.aarch64::nodejs:20, nodejs-1:20.12.2-2.module+el8.9.0+21743+0b3f1be2.ppc64le::nodejs:20, nodejs-1:20.12.2-2.module+el8.9.0+21743+0b3f1be2.s390x::nodejs:20 +20
- RHSA-2024:2779 Released 2024-05-09 · Red Hat rating Importantnodejs:18 security update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:18.20.2-2.module+el9.4.0+21742+692df1ea.aarch64::nodejs:18, nodejs-1:18.20.2-2.module+el9.4.0+21742+692df1ea.ppc64le::nodejs:18, nodejs-1:18.20.2-2.module+el9.4.0+21742+692df1ea.s390x::nodejs:18 +20
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2024:2778, RHSA-2024:2780 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2024:2779, RHSA-2024:2853, RHSA-2024:2910 |
| Red Hat Enterprise Linux AppStream E4S (v.9.0) | Fixed | RHSA-2024:4721 |
| Red Hat Enterprise Linux AppStream EUS (v.9.2) | Fixed | RHSA-2024:4559 |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22025
- 2026-10-03 Alias added: GHSA-xp28-3fv9-33c6
References
More NodeJS vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-18584 Race condition in NodeJS Node CVSS 3.0HIGH 8.2
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2024-22025 · CVE Program
- CVE-2024-22025 · NVD
- FIRST EPSS
- GHSA-xp28-3fv9-33c6 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-22025 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences