httparty Multipart/Form-Data Request Tampering Vulnerability
Priority MEDIUM 63CWE-472Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
httparty before 0.21.0 is vulnerable to an assumed-immutable web parameter vulnerability. A remote and unauthenticated attacker can provide a crafted filename parameter during multipart/form-data uploads which could result in attacker controlled filenames being written.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0129 70th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed httparty (RubyGems): 0.21.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | httparty | up to 0.20.0 | — | No fix listed | CNA |
| — | httparty (RubyGems) | before 0.21.0 | 0.21.0 | Patch available | GHSA-5pq7-52mg-hr42 |
- httparty Vendor— Affected up to 0.20.0 Fixed in — No fix listed CNA
- httparty (RubyGems) Vendor— Affected before 0.21.0 Fixed in 0.21.0 Patch available GHSA-5pq7-52mg-hr42
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
| cpe:2.3:a:jnunemaker:httparty:*:*:*:*:*:ruby:*:* | before 0.21.0 | Vulnerable | jnunemaker |
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
- cpe:2.3:a:jnunemaker:httparty:*:*:*:*:*:ruby:*:* Versions before 0.21.0 Vulnerable ·jnunemaker
Remediation
- Fix · GHSA-5pq7-52mg-hr42 httparty (RubyGems) Fixed in 0.21.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22049
- 2026-10-03 Alias added: GHSA-5pq7-52mg-hr42
References
Exploit 3
Advisory 3
Other 4
- https://lists.fedoraproject.org/archives/list/[email protected]/message/IOWECZPJY6JZIA5FSBJR77KCRDXWDZDA/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/4LDGAVPR4KB72V4GGQCWODEAI72QZI3V/
- https://github.com/jnunemaker/httparty
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/httparty/CVE-2024-22049.yml
Sources
- CVE-2024-22049 · CVE Program
- CVE-2024-22049 · NVD
- FIRST EPSS
- GHSA-5pq7-52mg-hr42 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-22049 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences