WordPress PeepSo Core: Photos Plugin < 6.3.1.0 is vulnerable to Cross Site Scripting (XSS)
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles allows Stored XSS.This issue affects Community by PeepSo – Social Network, Membership, Registration, User Profiles: from n/a before 6.3.1.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PeepSo | Community by PeepSo – Social Network, Membership, Registration, User Profiles | before 6.3.1.0 | 6.3.1.0 | Patch available | CNA |
- Community by PeepSo – Social Network, Membership, Registration, User Profiles VendorPeepSo Affected before 6.3.1.0 Fixed in 6.3.1.0 Patch available CNA
Remediation
- Fix · CNA Community by PeepSo – Social Network, Membership, Registration, User Profiles (PeepSo) Fixed in 6.3.1.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22158
- 2026-10-03 Alias added: GHSA-hc6c-m8v3-634f
References
More Peepso vulnerabilities
- TI-2024-00169 Community by PeepSo < 6.3.1.2 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2016-09006 The peepso-core plugin before 1.6.1 for WordPress has PeepSoProfilePreferencesAjax->save() privilege escalation. CVSS 3.1HIGH 8.8
- TI-2023-15395 WordPress Community by PeepSo Plugin <= 6.0.9.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-20824 WordPress Community by PeepSo Plugin <= 6.1.6.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-11212 WordPress Community by PeepSo Plugin <= 6.0.2.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2022-20031 WordPress Community by PeepSo Plugin <= 6.0.2.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2024-22158 · CVE Program
- CVE-2024-22158 · NVD
- FIRST EPSS
- GHSA-hc6c-m8v3-634f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences