Improper output encoding in Dell Unity
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Dell Unity, versions prior to 5.4, contain a vulnerability whereby log messages can be spoofed by an authenticated attacker. An attacker could exploit this vulnerability to forge log entries, create false alarms, and inject malicious content into logs that compromise logs integrity. A malicious attacker could also prevent the product from logging information while malicious actions are performed or implicate an arbitrary user for malicious activities.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Unity | before 5.3.0.0.5.120 | 5.3.0.0.5.120 | Patch available | CNA |
- Unity VendorDell Affected before 5.3.0.0.5.120 Fixed in 5.3.0.0.5.120 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dell:unity_operating_environment:5.3.0.0.5.120:*:*:*:*:*:*:* | 5.3.0.0.5.120 | Vulnerable | Dell |
| cpe:2.3:a:dell:unity_xt_operating_environment:5.3.0.0.5.120:*:*:*:*:*:*:* | 5.3.0.0.5.120 | Vulnerable | Dell |
| cpe:2.3:a:dell:unityvsa_operating_environment:5.3.0.0.5.120:*:*:*:*:*:*:* | 5.3.0.0.5.120 | Vulnerable | Dell |
- cpe:2.3:a:dell:unity_operating_environment:5.3.0.0.5.120:*:*:*:*:*:*:* Versions 5.3.0.0.5.120 Vulnerable ·Dell
- cpe:2.3:a:dell:unity_xt_operating_environment:5.3.0.0.5.120:*:*:*:*:*:*:* Versions 5.3.0.0.5.120 Vulnerable ·Dell
- cpe:2.3:a:dell:unityvsa_operating_environment:5.3.0.0.5.120:*:*:*:*:*:*:* Versions 5.3.0.0.5.120 Vulnerable ·Dell
Remediation
- Fix · CNA Unity (Dell) Fixed in 5.3.0.0.5.120
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22229
- 2026-10-03 Alias added: GHSA-63fr-hqmm-7x7r
References
More Dell Unity Operating Environment vulnerabilities
- TI-2025-24909 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-16296 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2024-33087 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-18126 OS command injection in Dell Unity CVSS 3.1CRITICAL 9.1
- TI-2022-11638 Missing brute-force protection in Dell Unity CVSS 3.1CRITICAL 9.8
- TI-2025-18125 OS command injection in Dell Unity CVSS 3.1HIGH 7.3
Sources
- CVE-2024-22229 · CVE Program
- CVE-2024-22229 · NVD
- FIRST EPSS
- GHSA-63fr-hqmm-7x7r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences