Read the docs
TI-2024-15007 Aliases CVE-2024-22437GHSA-24vx-27hc-7h4h

HPE MSA SAN Storage VSS Provider and CAPI Proxy Software, Elevation of Privilege

Priority LOW 33CWE-428Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-428.

Summary

A potential security vulnerability has been identified in VSS Provider and CAPI Proxy software for certain HPE MSA storage products. This vulnerability could be exploited to gain elevated privilege on the system.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00181 7th percentileScored 2026-11-07
Fix Fixed HPE MSA SAN Storage VSS Provider and CAPI Proxy Software (Hewlett Packard Enterprise): 4.1.3.83

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Hewlett Packard EnterpriseHPE MSA SAN Storage VSS Provider and CAPI Proxy SoftwareN/A to before 4.1.3.834.1.3.83Patch availableCNA
  • HPE MSA SAN Storage VSS Provider and CAPI Proxy Software VendorHewlett Packard Enterprise Affected N/A to before 4.1.3.83 Fixed in 4.1.3.83 Patch available CNA

Remediation

  • Fix · CNA HPE MSA SAN Storage VSS Provider and CAPI Proxy Software (Hewlett Packard Enterprise) Fixed in 4.1.3.83

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-22437
  2. 2026-10-03 Alias added: GHSA-24vx-27hc-7h4h

References

  • TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
  • TI-2015-02747 Heap-based buffer overflow in Adobe Flash Player before 13.0.0.296 and 14.x through 18.x… KEVCVSS 3.1CRITICAL 9.8
  • TI-2013-04219 HP ProCurve Manager (PCM) 3.20 and 4.0, PCM+ 3.20 and 4.0, Identity Driven Manager (IDM)… KEVCVSS 3.1CRITICAL 9.8
  • TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
  • TI-2005-02634 HP OpenView Network Node Manager 6.2 through 7.50 allows remote attackers to execute… KEVCVSS 3.1CRITICAL 9.8
  • TI-2015-07113 Integer overflow in Adobe Flash Player before 18.0.0.324 and 19.x and 20.x before… KEVCVSS 3.1HIGH 8.8
See all 2514 →

Sources