Uncontrolled search path in Dell Alienware Command Center
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-427.
Summary
Dell Alienware Command Center, versions prior to 6.2.7.0, contain an uncontrolled search path element vulnerability. A local malicious user could potentially inject malicious files in the file search path, leading to system compromise.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Alienware Command Center (AWCC) (Dell) Fixed in 6.2.7.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Dell Alienware Command Center (AWCC) — dell.com/support/kbdoc/en-us/000218222/dsa-2024-016-securit…
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2024-00147 Dell Alienware Command Center, versions 5.5.52.0 and prior, contain improper access…Priority LOW 31
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22450
- 2026-10-03 Alias added: GHSA-gw7j-rv4v-wrcj
References
More Dell Alienware Command Center vulnerabilities
- TI-2023-12652 Deserialization of untrusted data in Dell Alienware Command Center CVSS 3.1HIGH 7.8
- TI-2026-25160 Dell Alienware Command Center (AWCC), versions prior to 6.13.8.0, contain a Least… CVSS 3.1HIGH 7.8
- TI-2026-20946 Dell Alienware Command Center (AWCC), versions prior to 6.13.8.0, contain an Execution… CVSS 3.1HIGH 7.8
- TI-2026-19753 Improper privilege management in Dell Alienware Command Center CVSS 3.1HIGH 7.8
- TI-2025-29104 Dell Alienware Command Center 6.x (AWCC), versions prior to 6.10.15.0, contains an… CVSS 3.1HIGH 7.8
- TI-2025-29102 Dell Alienware Command Center 6.x (AWCC), versions prior to 6.10.15.0, contain a… CVSS 3.1HIGH 7.8
Sources
- CVE-2024-22450 · CVE Program
- CVE-2024-22450 · NVD
- FIRST EPSS
- GHSA-gw7j-rv4v-wrcj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences