Stupid Simple CMS <=1.2.4 is vulnerable to Cross Site Scripting (XSS) in the editing section of the article content.
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Stupid Simple CMS <=1.2.4 is vulnerable to Cross Site Scripting (XSS) in the editing section of the article content.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00376 31st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22714
- 2026-10-03 Alias added: GHSA-m7rj-gf65-6q26
References
More codelyfe Stupid Simple Cms vulnerabilities
- TI-2024-18351 Stupid Simple CMS v1.2.4 was discovered to contain a Cross-Site Request Forgery (CSRF) via /update-article.php. CVSS 3.1HIGH 8.8
- TI-2024-15107 Stupid Simple CMS <=1.2.4 was discovered to contain a Cross-Site Request Forgery (CSRF)… CVSS 3.1HIGH 8.8
- TI-2024-18302 Stupid Simple CMS v1.2.4 was discovered to contain a Cross-Site Request Forgery (CSRF)… CVSS 3.1MEDIUM 6.3
- TI-2024-18301 Stupid Simple CMS 1.2.4 is vulnerable to Cross Site Scripting (XSS) within the blog title of the settings. CVSS 3.1MEDIUM 6.1
- TI-2024-03002 codelyfe Stupid Simple CMS Login Page excessive authentication CVSS 3.1MEDIUM 5.9
- TI-2023-06306 codelyfe Stupid Simple CMS HTTP POST Request handle-command.php os command injection CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-22714 · CVE Program
- CVE-2024-22714 · NVD
- FIRST EPSS
- GHSA-m7rj-gf65-6q26 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences