Improper certificate validation in Apple Safari
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-295.
Summary
This issue was addressed through improved state management. This issue is fixed in Safari 17.4, iOS 17.4 and iPadOS 17.4, macOS Sonoma 14.4. Private Browsing tabs may be accessed without authentication.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apple | Safari | before 17.4 | 17.4 | Patch available | CNA |
| Apple | iOS and iPadOS | before 17.4 | 17.4 | Patch available | CNA |
| Apple | macOS | before 14.4 | 14.4 | Patch available | CNA |
- Safari VendorApple Affected before 17.4 Fixed in 17.4 Patch available CNA
- iOS and iPadOS VendorApple Affected before 17.4 Fixed in 17.4 Patch available CNA
- macOS VendorApple Affected before 14.4 Fixed in 14.4 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:* | before 17.4 | Vulnerable | Apple |
| cpe:2.3:o:apple:ipad_os:*:*:*:*:*:*:*:* | before 17.4 | Vulnerable | Apple |
| cpe:2.3:o:apple:iphone_os:*:*:*:*:*:*:*:* | before 17.4 | Vulnerable | Apple |
| cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* | 14.0 to before 14.4 | Vulnerable | Apple |
- cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:* Versions before 17.4 Vulnerable ·Apple
- cpe:2.3:o:apple:ipad_os:*:*:*:*:*:*:*:* Versions before 17.4 Vulnerable ·Apple
- cpe:2.3:o:apple:iphone_os:*:*:*:*:*:*:*:* Versions before 17.4 Vulnerable ·Apple
- cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* Versions 14.0 to before 14.4 Vulnerable ·Apple
Remediation
- Fix · CNA Safari (Apple) Fixed in 17.4
- Fix · CNA iOS and iPadOS (Apple) Fixed in 17.4
- Fix · CNA macOS (Apple) Fixed in 14.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple macOS 14.4
36 records Highest priority Priority MEDIUM 6 MEDIUM, 30 LOW
Other records, highest priority first
- TI-2024-15360 Incorrect authorization in Apple iOS and iPadOSPriority MEDIUM 48
- TI-2024-00233 Improper access control in Apple iOS and iPadOSPriority MEDIUM 45
- TI-2024-15332 Out-of-bounds write in Apple iOS and iPadOSPriority MEDIUM 42
- Release ·
Apple iOS and iPadOS 17.4
22 records Highest priority Priority MEDIUM 4 MEDIUM, 18 LOW
Other records, highest priority first
- TI-2024-15360 Incorrect authorization in Apple iOS and iPadOSPriority MEDIUM 48
- TI-2024-00233 Improper access control in Apple iOS and iPadOSPriority MEDIUM 45
- TI-2024-15332 Out-of-bounds write in Apple iOS and iPadOSPriority MEDIUM 42
Show 1 more group
- Release ·
Apple Safari 17.4
5 records Highest priority Priority MEDIUM 1 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2024-15368 Improper input validation in Apple SafariPriority MEDIUM 40
- TI-2024-15385 Injection in Apple SafariPriority LOW 35
- TI-2024-15389 Protection mechanism failure in Apple SafariPriority LOW 32
Timeline
- 2026-10-02 Threatist record created from CVE-2024-23273
- 2026-10-03 Alias added: GHSA-qg9g-p9q2-wjvw
References
More Apple Ipad Os vulnerabilities
- TI-2022-06888 Use after free in Apple Safari CVSS 3.1HIGH 8.8
- TI-2022-06876 Out-of-bounds write in Apple Safari CVSS 3.1HIGH 8.8
- TI-2024-15360 Incorrect authorization in Apple iOS and iPadOS CVSS 3.1CRITICAL 9.1
- TI-2021-01529 Apple iOS and iPadOS: A remote attacker may be able to cause unexpected application… CVSS 3.1CRITICAL 9.8
- TI-2021-01509 Out-of-bounds write in Apple iOS and iPadOS CVSS 3.1CRITICAL 9.8
- TI-2021-01508 Out-of-bounds write in Apple iOS and iPadOS CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-23273 · CVE Program
- CVE-2024-23273 · NVD
- FIRST EPSS
- GHSA-qg9g-p9q2-wjvw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences