Elasticsearch elasticsearch-certutil csr fails to encrypt private key
Priority LOW 32CWE-311Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311.
Summary
It was discovered by Elastic engineering that when elasticsearch-certutil CLI tool is used with the csr option in order to create a new Certificate Signing Requests, the associated private key that is generated is stored on disk unencrypted even if the --pass parameter is passed in the command invocation.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00206 10th percentileScored 2026-11-07
Fix Fixed Elasticsearch (Elastic): 7.17.23, 8.13.0org.elasticsearch:elasticsearch (Maven): 8.13.0, 7.17.23
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Elasticsearch | 7.x to before 7.17.23; 8.x to before 8.13.0 | 7.17.23, 8.13.0 | Patch available | CNA |
| — | org.elasticsearch:elasticsearch (Maven) | 8.0.0-alpha1 to before 8.13.0 | 8.13.0 | Patch available | GHSA-5v8f-xx9m-wj44 |
| — | org.elasticsearch:elasticsearch (Maven) | before 7.17.23 | 7.17.23 | Patch available | GHSA-5v8f-xx9m-wj44 |
- Elasticsearch VendorElastic Affected 7.x to before 7.17.23; 8.x to before 8.13.0 Fixed in 7.17.23, 8.13.0 Patch available CNA
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected 8.0.0-alpha1 to before 8.13.0 Fixed in 8.13.0 Patch available GHSA-5v8f-xx9m-wj44
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected before 7.17.23 Fixed in 7.17.23 Patch available GHSA-5v8f-xx9m-wj44
Remediation
- Fix · CNA Elasticsearch (Elastic) Fixed in 7.17.23, 8.13.0
- Fix · GHSA-5v8f-xx9m-wj44 org.elasticsearch:elasticsearch (Maven) Fixed in 8.13.0 Advisory →
- Fix · GHSA-5v8f-xx9m-wj44 org.elasticsearch:elasticsearch (Maven) Fixed in 7.17.23 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-23444
- 2026-10-03 Alias added: GHSA-5v8f-xx9m-wj44
References
Advisory 2
Other 7
- https://github.com/elastic/elasticsearch/pull/106105
- https://github.com/elastic/elasticsearch/pull/109834
- https://github.com/elastic/elasticsearch/commit/07296d596a1dee24730e33ad40b6726f70c6fc23
- https://github.com/elastic/elasticsearch/commit/321c4e1e6b738bf80faa41dbb9881489a4ab44e5
- https://github.com/elastic/elasticsearch/commit/bb1eddada3678257838b0590090ff9eb68acaa1b
- https://github.com/elastic/elasticsearch
- https://security.netapp.com/advisory/ntap-20250404-0001
More Elasticsearch vulnerabilities
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
- TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
- TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-23444 · CVE Program
- CVE-2024-23444 · NVD
- FIRST EPSS
- GHSA-5v8f-xx9m-wj44 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences