Elasticsearch Uncontrolled Resource Consumption vulnerability
Priority LOW 35CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
A flaw was discovered in Elasticsearch, where processing a document in a deeply nested pipeline on an ingest node could cause the Elasticsearch node to crash.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01254 69th percentileScored 2026-11-07
Fix Partial Elasticsearch (Elastic): 7.17.19, 8.13.0org.elasticsearch:elasticsearch (Maven): 7.17.19, 8.13.0Red Hat: 1 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Elasticsearch | 7.0.0 to before 7.17.19; 8.0.0 to before 8.13.0 | 7.17.19, 8.13.0 | Patch available | CNA |
| — | org.elasticsearch:elasticsearch (Maven) | 7.0.0 to before 7.17.19 | 7.17.19 | Patch available | GHSA-w5gg-2q56-6h4f |
| — | org.elasticsearch:elasticsearch (Maven) | 8.0.0 to before 8.13.0 | 8.13.0 | Patch available | GHSA-w5gg-2q56-6h4f |
- Elasticsearch VendorElastic Affected 7.0.0 to before 7.17.19; 8.0.0 to before 8.13.0 Fixed in 7.17.19, 8.13.0 Patch available CNA
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected 7.0.0 to before 7.17.19 Fixed in 7.17.19 Patch available GHSA-w5gg-2q56-6h4f
- org.elasticsearch:elasticsearch (Maven) Vendor— Affected 8.0.0 to before 8.13.0 Fixed in 8.13.0 Patch available GHSA-w5gg-2q56-6h4f
Remediation
- Fix · CNA Elasticsearch (Elastic) Fixed in 7.17.19, 8.13.0
- Fix · GHSA-w5gg-2q56-6h4f org.elasticsearch:elasticsearch (Maven) Fixed in 7.17.19 Advisory →
- Fix · GHSA-w5gg-2q56-6h4f org.elasticsearch:elasticsearch (Maven) Fixed in 8.13.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Quay 3 | Affected | No fix planned: Will not fix |
Not affected: 3 products
- Logging Subsystem for Red Hat OpenShift
- Red Hat OpenStack Platform 16.1
- Red Hat OpenStack Platform 16.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-23450
- 2026-10-03 Alias added: GHSA-w5gg-2q56-6h4f
References
Advisory 4
More Elasticsearch vulnerabilities
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
- TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
- TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-23450 · CVE Program
- CVE-2024-23450 · NVD
- FIRST EPSS
- GHSA-w5gg-2q56-6h4f · GitHub Advisory Database · CC BY 4.0
- CVE-2024-23450 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences