AntiSamy malicious input can provoke XSS when preserving comments
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to 1.7.5, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. Patched in AntiSamy 1.7.5 and later.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nahsra | antisamy | before 1.7.5 | 1.7.5 | Patch available | CNA |
| — | org.owasp.antisamy:antisamy (Maven) | before 1.7.5 | 1.7.5 | Patch available | GHSA-2mrq-w8pv-5pvq |
- antisamy Vendornahsra Affected before 1.7.5 Fixed in 1.7.5 Patch available CNA
- org.owasp.antisamy:antisamy (Maven) Vendor— Affected before 1.7.5 Fixed in 1.7.5 Patch available GHSA-2mrq-w8pv-5pvq
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:antisamy_project:antisamy:*:*:*:*:*:*:*:* | before 1.7.5 | Vulnerable | Antisamy Project |
- cpe:2.3:a:antisamy_project:antisamy:*:*:*:*:*:*:*:* Versions before 1.7.5 Vulnerable ·Antisamy Project
Remediation
- Fix · CNA antisamy (nahsra) Fixed in 1.7.5
- Fix · GHSA-2mrq-w8pv-5pvq org.owasp.antisamy:antisamy (Maven) Fixed in 1.7.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-23635
- 2026-10-03 Alias added: GHSA-2mrq-w8pv-5pvq
References
Advisory 2
More Antisamy Project Antisamy vulnerabilities
- TI-2022-11120 Certain Neko-related HTML parsers allow a denial of service via crafted Processing… CVSS 3.1HIGH 7.5
- TI-2016-08102 In OWASP AntiSamy before 1.5.5, by submitting a specially crafted input (a tag that… CVSS 3.1MEDIUM 6.1
- TI-2017-10799 OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of… CVSS 3.0MEDIUM 6.1
- TI-2022-12015 OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with… CVSS 3.1MEDIUM 6.1
- TI-2021-14007 OWASP AntiSamy before 1.6.4 allows XSS via HTML attributes when using the HTML output… CVSS 3.1MEDIUM 6.1
- TI-2022-11121 OWASP AntiSamy before 1.6.6 allows XSS via HTML tag smuggling on STYLE content with… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-23635 · CVE Program
- CVE-2024-23635 · NVD
- FIRST EPSS
- GHSA-2mrq-w8pv-5pvq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences