Read the docs
TI-2024-15660 Aliases CVE-2024-23641GHSA-g5m6-hxpp-fc49

Sending a GET or HEAD request with a body crashes SvelteKit

Priority HIGH 72CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

SvelteKit is a web development kit. In SvelteKit 2, sending a GET request with a body eg `{}` to a built and previewed/hosted sveltekit app throws `Request with GET/HEAD method cannot have body.` and crashes the preview/hosting. After this happens, one must manually restart the app. `TRACE` requests will also cause the app to crash. Prerendered pages and SvelteKit 1 apps are not affected. `@sveltejs/adapter-node` versions 2.1.2, 3.0.3, and 4.0.1 and `@sveltejs/kit` version 2.4.3 contain a patch for this issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00764 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed kit (sveltejs): 2.4.3, 2.1.2, 3.0.3@sveltejs/kit (npm): 2.4.3+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
sveltejskit2.0.0 to before 2.4.3; 2.0.0 to before 2.1.2; 3.0.0 to before 3.0.3; = 4.0.02.4.3, 2.1.2, 3.0.3Patch availableCNA
—@sveltejs/kit (npm)2.0.0 to before 2.4.32.4.3Patch availableGHSA-g5m6-hxpp-fc49
—@sveltejs/adapter-node (npm)2.0.0 to before 2.1.22.1.2Patch availableGHSA-g5m6-hxpp-fc49
—@sveltejs/adapter-node (npm)3.0.0 to before 3.0.33.0.3Patch availableGHSA-g5m6-hxpp-fc49
—@sveltejs/adapter-node (npm)4.0.0 to before 4.0.14.0.1Patch availableGHSA-g5m6-hxpp-fc49
  • kit Vendorsveltejs Affected 2.0.0 to before 2.4.3; 2.0.0 to before 2.1.2; 3.0.0 to before 3.0.3; = 4.0.0 Fixed in 2.4.3, 2.1.2, 3.0.3 Patch available CNA
  • @sveltejs/kit (npm) Vendor— Affected 2.0.0 to before 2.4.3 Fixed in 2.4.3 Patch available GHSA-g5m6-hxpp-fc49
  • @sveltejs/adapter-node (npm) Vendor— Affected 2.0.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-g5m6-hxpp-fc49
  • @sveltejs/adapter-node (npm) Vendor— Affected 3.0.0 to before 3.0.3 Fixed in 3.0.3 Patch available GHSA-g5m6-hxpp-fc49
  • @sveltejs/adapter-node (npm) Vendor— Affected 4.0.0 to before 4.0.1 Fixed in 4.0.1 Patch available GHSA-g5m6-hxpp-fc49

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:svelte:adapter-node:*:*:*:*:*:node.js:*:*2.0.0 to before 2.1.2; 3.0.0 to before 3.0.3Vulnerablesveltejs
cpe:2.3:a:svelte:adapter-node:4.0.0:*:*:*:*:node.js:*:*4.0.0Vulnerablesveltejs
cpe:2.3:a:svelte:kit:*:*:*:*:*:node.js:*:*2.0.0 to before 2.4.3Vulnerablesveltejs
  • cpe:2.3:a:svelte:adapter-node:*:*:*:*:*:node.js:*:* Versions 2.0.0 to before 2.1.2; 3.0.0 to before 3.0.3 Vulnerable ·sveltejs
  • cpe:2.3:a:svelte:adapter-node:4.0.0:*:*:*:*:node.js:*:* Versions 4.0.0 Vulnerable ·sveltejs
  • cpe:2.3:a:svelte:kit:*:*:*:*:*:node.js:*:* Versions 2.0.0 to before 2.4.3 Vulnerable ·sveltejs

Remediation

  • Fix · CNA kit (sveltejs) Fixed in 2.4.3, 2.1.2, 3.0.3
  • Fix · GHSA-g5m6-hxpp-fc49 @sveltejs/kit (npm) Fixed in 2.4.3 Advisory →
  • Fix · GHSA-g5m6-hxpp-fc49 @sveltejs/adapter-node (npm) Fixed in 2.1.2 Advisory →
  • Fix · GHSA-g5m6-hxpp-fc49 @sveltejs/adapter-node (npm) Fixed in 3.0.3 Advisory →
  • Fix · GHSA-g5m6-hxpp-fc49 @sveltejs/adapter-node (npm) Fixed in 4.0.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-23641
  2. 2026-10-03 Alias added: GHSA-g5m6-hxpp-fc49

References

  • TI-2025-41390 SvelteKit Denial of service and possible SSRF when using prerendering CVSS 4.0HIGH 8.4

Sources