SvelteKit Denial of service and possible SSRF when using prerendering
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- High · Low · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-248.
Summary
SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| sveltejs | kit | 2.19.0 to before 2.49.5 | 2.49.5 | Patch available | CNA |
| — | @sveltejs/kit (npm) | 2.19.0 to before 2.49.5 | 2.49.5 | Patch available | GHSA-j62c-4x62-9r35 |
| — | @sveltejs/adapter-node (npm) | 5.4.1 to before 5.5.1 | 5.5.1 | Patch available | GHSA-j62c-4x62-9r35 |
- kit Vendorsveltejs Affected 2.19.0 to before 2.49.5 Fixed in 2.49.5 Patch available CNA
- @sveltejs/kit (npm) Vendor— Affected 2.19.0 to before 2.49.5 Fixed in 2.49.5 Patch available GHSA-j62c-4x62-9r35
- @sveltejs/adapter-node (npm) Vendor— Affected 5.4.1 to before 5.5.1 Fixed in 5.5.1 Patch available GHSA-j62c-4x62-9r35
Remediation
- Fix · CNA kit (sveltejs) Fixed in 2.49.5
- Fix · GHSA-j62c-4x62-9r35 @sveltejs/kit (npm) Fixed in 2.49.5 Advisory →
- Fix · GHSA-j62c-4x62-9r35 @sveltejs/adapter-node (npm) Fixed in 5.5.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-67647
- 2026-10-03 Alias added: GHSA-j62c-4x62-9r35
References
Advisory 2
More sveltejs Adapter-node vulnerabilities
- TI-2024-15660 Sending a GET or HEAD request with a body crashes SvelteKit CVSS 3.1HIGH 7.5
Sources
- CVE-2025-67647 · CVE Program
- CVE-2025-67647 · NVD
- FIRST EPSS
- GHSA-j62c-4x62-9r35 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences