The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow…
Priority MEDIUM 51CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01202 68th percentileScored 2026-11-07
Fix Fixed llama-hub (PyPI): 0.0.67
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | llama-hub (PyPI) | before 0.0.67 | 0.0.67 | Patch available | GHSA-297x-2qf3-jrj3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- llama-hub (PyPI) Vendor— Affected before 0.0.67 Fixed in 0.0.67 Patch available GHSA-297x-2qf3-jrj3
Remediation
- Fix · GHSA-297x-2qf3-jrj3 llama-hub (PyPI) Fixed in 0.0.67 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-23730
- 2026-10-03 Alias added: GHSA-297x-2qf3-jrj3
References
Patch 1
Other 6
- https://github.com/run-llama/llama-hub/releases/tag/v0.0.67
- https://github.com/run-llama/llama-hub/blob/v0.0.67/CHANGELOG.md
- https://github.com/run-llama/llama-hub/commit/c01416e737c7747a213a79881b8308c41d043515
- https://github.com/pypa/advisory-database/tree/main/vulns/llama-hub/PYSEC-2026-393.yaml
- https://github.com/run-llama/llama-hub
- https://pypi.org/project/llama-hub
Sources
- CVE-2024-23730 · CVE Program
- CVE-2024-23730 · NVD
- FIRST EPSS
- GHSA-297x-2qf3-jrj3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences