The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary…
Priority MEDIUM 51CWE-88Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-88.
Summary
The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0105 64th percentileScored 2026-11-07
Fix Fixed embedchain (PyPI): 0.1.57
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | embedchain (PyPI) | before 0.1.57 | 0.1.57 | Patch available | GHSA-rhhj-5436-95vf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- embedchain (PyPI) Vendor— Affected before 0.1.57 Fixed in 0.1.57 Patch available GHSA-rhhj-5436-95vf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:embedchain:embedchain:*:*:*:*:*:*:*:* | before 0.1.57 | Vulnerable | Embedchain |
- cpe:2.3:a:embedchain:embedchain:*:*:*:*:*:*:*:* Versions before 0.1.57 Vulnerable ·Embedchain
Remediation
- Fix · GHSA-rhhj-5436-95vf embedchain (PyPI) Fixed in 0.1.57 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-23731
- 2026-10-03 Alias added: GHSA-rhhj-5436-95vf
References
Patch 2
More Embedchain vulnerabilities
- TI-2024-15736 The JSON loader in Embedchain before 0.1.57 allows a ReDoS (regular expression denial of… CVSS 3.1HIGH 7.5
Sources
- CVE-2024-23731 · CVE Program
- CVE-2024-23731 · NVD
- FIRST EPSS
- GHSA-rhhj-5436-95vf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences