Read the docs
TI-2024-16814 Aliases CVE-2024-25581GHSA-55g9-rgmx-hvww

Transfer requests received over DoH can lead to a denial of service in DNSdist

Priority MEDIUM 41CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

When incoming DNS over HTTPS support is enabled using the nghttp2 provider, and queries are routed to a tcp-only or DNS over TLS backend, an attacker can trigger an assertion failure in DNSdist by sending a request for a zone transfer (AXFR or IXFR) over DNS over HTTPS, causing the process to stop and thus leading to a Denial of Service. DNS over HTTPS is not enabled by default, and backends are using plain DNS (Do53) by default.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01078 65th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PowerDNSDNSdist1.9.0; 1.9.1; 1.9.2; 1.9.3—No fix listedCNA
  • DNSdist VendorPowerDNS Affected 1.9.0; 1.9.1; 1.9.2; 1.9.3 Fixed in — No fix listed CNA

CPE names CISA-ADP · 4

CPEVersionsRoleVendor
cpe:2.3:a:powerdns:dnsdist:1.9.0:*:*:*:*:*:*:*1.9.0—PowerDNS
cpe:2.3:a:powerdns:dnsdist:1.9.1:*:*:*:*:*:*:*1.9.1—PowerDNS
cpe:2.3:a:powerdns:dnsdist:1.9.2:*:*:*:*:*:*:*1.9.2—PowerDNS
cpe:2.3:a:powerdns:dnsdist:1.9.3:*:*:*:*:*:*:*1.9.3—PowerDNS
  • cpe:2.3:a:powerdns:dnsdist:1.9.0:*:*:*:*:*:*:* Versions 1.9.0 — ·PowerDNS
  • cpe:2.3:a:powerdns:dnsdist:1.9.1:*:*:*:*:*:*:* Versions 1.9.1 — ·PowerDNS
  • cpe:2.3:a:powerdns:dnsdist:1.9.2:*:*:*:*:*:*:* Versions 1.9.2 — ·PowerDNS
  • cpe:2.3:a:powerdns:dnsdist:1.9.3:*:*:*:*:*:*:* Versions 1.9.3 — ·PowerDNS

Remediation

No fixed version listed by the sources yet.

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-25581
  2. 2026-10-03 Alias added: GHSA-55g9-rgmx-hvww

References

  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
  • TI-2021-14878 PowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by… CVSS 3.1HIGH 7.5
  • TI-2016-04703 PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a . CVSS 3.0HIGH 7.5
  • TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
See all 130 →

Sources