Crafted responses can lead to a denial of service due to cache inefficiencies in the Recursor
Priority LOW 34CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An attacker can publish a zone containing specific Resource Record Sets. Repeatedly processing and caching results for these sets can lead to a denial of service.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00698 53rd percentileScored 2026-11-07
Fix Fixed Recursor (PowerDNS): 4.9.9, 5.0.9, 5.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PowerDNS | Recursor | before 4.9.9; 5.0.0 to before 5.0.9; 5.1.0 to before 5.1.2 | 4.9.9, 5.0.9, 5.1.2 | Patch available | CNA |
- Recursor VendorPowerDNS Affected before 4.9.9; 5.0.0 to before 5.0.9; 5.1.0 to before 5.1.2 Fixed in 4.9.9, 5.0.9, 5.1.2 Patch available CNA
Remediation
- Fix · CNA Recursor (PowerDNS) Fixed in 4.9.9, 5.0.9, 5.1.2
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-25590
- 2026-10-03 Alias added: GHSA-pvmx-j29h-323g
References
More PowerDNS vulnerabilities
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
- TI-2021-14878 PowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by… CVSS 3.1HIGH 7.5
- TI-2016-04703 PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a . CVSS 3.0HIGH 7.5
- TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
Sources
- CVE-2024-25590 · CVE Program
- CVE-2024-25590 · NVD
- FIRST EPSS
- GHSA-pvmx-j29h-323g · GitHub Advisory Database · CC BY 4.0
- CVE-2024-25590 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences