Read the docs
TI-2024-17076 Aliases CVE-2024-25978GHSA-487g-3m3v-hjhq

Msa-24-0001: denial of service risk in file picker unzip functionality

Priority LOW 35CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.

Summary

Insufficient file size checks resulted in a denial of service risk in the file picker's unzip functionality.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00944 61st percentileScored 2026-11-07
Fix Fixed moodle: 4.3.3, 4.2.6, 4.1.9moodle/moodle (Packagist): 4.3.3, 4.2.6, 4.1.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle4.3.0 to before 4.3.3; 4.2.0 to before 4.2.6; before 4.1.94.3.3, 4.2.6, 4.1.9Patch availableCNA
—moodle/moodle (Packagist)4.3.0 to before 4.3.34.3.3Patch availableGHSA-487g-3m3v-hjhq
—moodle/moodle (Packagist)4.2.0 to before 4.2.64.2.6Patch availableGHSA-487g-3m3v-hjhq
—moodle/moodle (Packagist)before 4.1.94.1.9Patch availableGHSA-487g-3m3v-hjhq
  • moodle Vendor— Affected 4.3.0 to before 4.3.3; 4.2.0 to before 4.2.6; before 4.1.9 Fixed in 4.3.3, 4.2.6, 4.1.9 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected 4.3.0 to before 4.3.3 Fixed in 4.3.3 Patch available GHSA-487g-3m3v-hjhq
  • moodle/moodle (Packagist) Vendor— Affected 4.2.0 to before 4.2.6 Fixed in 4.2.6 Patch available GHSA-487g-3m3v-hjhq
  • moodle/moodle (Packagist) Vendor— Affected before 4.1.9 Fixed in 4.1.9 Patch available GHSA-487g-3m3v-hjhq

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*4.1.0 to before 4.1.9; 4.2.0 to before 4.2.6; 4.3.0 to before 4.3.3VulnerableMoodle
cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:*38VulnerableFedoraproject
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 4.1.0 to before 4.1.9; 4.2.0 to before 4.2.6; 4.3.0 to before 4.3.3 Vulnerable ·Moodle
  • cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject

Remediation

  • Fix · CNA moodle Fixed in 4.3.3, 4.2.6, 4.1.9
  • Fix · GHSA-487g-3m3v-hjhq moodle/moodle (Packagist) Fixed in 4.3.3 Advisory →
  • Fix · GHSA-487g-3m3v-hjhq moodle/moodle (Packagist) Fixed in 4.2.6 Advisory →
  • Fix · GHSA-487g-3m3v-hjhq moodle/moodle (Packagist) Fixed in 4.1.9 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-25978
  2. 2026-10-03 Alias added: GHSA-487g-3m3v-hjhq

References

Sources