Msa-24-0005: csrf risk in language import utility
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
The link to update all installed language packs did not include the necessary token to prevent a CSRF risk.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.005 43rd percentileScored 2026-11-07
Fix Fixed moodle: 4.3.3, 4.2.6, 4.1.9moodle/moodle (Packagist): 4.3.3, 4.2.6, 4.1.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.3.0 to before 4.3.3; 4.2.0 to before 4.2.6; before 4.1.9 | 4.3.3, 4.2.6, 4.1.9 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 4.3.0 to before 4.3.3 | 4.3.3 | Patch available | GHSA-7pjp-fm93-p6pj |
| — | moodle/moodle (Packagist) | 4.2.0 to before 4.2.6 | 4.2.6 | Patch available | GHSA-7pjp-fm93-p6pj |
| — | moodle/moodle (Packagist) | before 4.1.9 | 4.1.9 | Patch available | GHSA-7pjp-fm93-p6pj |
- moodle Vendor— Affected 4.3.0 to before 4.3.3; 4.2.0 to before 4.2.6; before 4.1.9 Fixed in 4.3.3, 4.2.6, 4.1.9 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 4.3.0 to before 4.3.3 Fixed in 4.3.3 Patch available GHSA-7pjp-fm93-p6pj
- moodle/moodle (Packagist) Vendor— Affected 4.2.0 to before 4.2.6 Fixed in 4.2.6 Patch available GHSA-7pjp-fm93-p6pj
- moodle/moodle (Packagist) Vendor— Affected before 4.1.9 Fixed in 4.1.9 Patch available GHSA-7pjp-fm93-p6pj
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 4.1.0 to before 4.1.9; 4.2.0 to before 4.2.6; 4.3.0 to before 4.3.3 | Vulnerable | Moodle |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 4.1.0 to before 4.1.9; 4.2.0 to before 4.2.6; 4.3.0 to before 4.3.3 Vulnerable ·Moodle
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA moodle Fixed in 4.3.3, 4.2.6, 4.1.9
- Fix · GHSA-7pjp-fm93-p6pj moodle/moodle (Packagist) Fixed in 4.3.3 Advisory →
- Fix · GHSA-7pjp-fm93-p6pj moodle/moodle (Packagist) Fixed in 4.2.6 Advisory →
- Fix · GHSA-7pjp-fm93-p6pj moodle/moodle (Packagist) Fixed in 4.1.9 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-25982
- 2026-10-03 Alias added: GHSA-7pjp-fm93-p6pj
References
Advisory 2
Other 5
- RHBZ#2264098
- https://lists.fedoraproject.org/archives/list/[email protected]/message/KXGBYJ43BUEBUAQZU3DT5I5A3YLF47CB/
- https://github.com/moodle/moodle/commit/bac703c534d05d4502580fbe32447d5c777869bf
- https://github.com/moodle/moodle
- https://lists.fedoraproject.org/archives/list/[email protected]/message/KXGBYJ43BUEBUAQZU3DT5I5A3YLF47CB
Sources
- CVE-2024-25982 · CVE Program
- CVE-2024-25982 · NVD
- FIRST EPSS
- GHSA-7pjp-fm93-p6pj · GitHub Advisory Database · CC BY 4.0
- CVE-2024-25982 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences