1Panel open source panel project has an unauthorized vulnerability.
Priority MEDIUM 61CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
1Panel is an open source Linux server operation and maintenance management panel. Prior to version 1.10.1-lts, users can use Burp to obtain unauthorized access to the console page. The vulnerability has been fixed in v1.10.1-lts. There are no known workarounds.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00471 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed 1Panel (1Panel-dev): 1.10.1-ltsgithub.com/1Panel-dev/1Panel (Go): 1.10.1-lts
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| 1Panel-dev | 1Panel | before 1.10.1-lts | 1.10.1-lts | Patch available | CNA |
| — | github.com/1Panel-dev/1Panel (Go) | before 1.10.1-lts | 1.10.1-lts | Patch available | GHSA-26w3-q4j8-4xjp |
- 1Panel Vendor1Panel-dev Affected before 1.10.1-lts Fixed in 1.10.1-lts Patch available CNA
- github.com/1Panel-dev/1Panel (Go) Vendor— Affected before 1.10.1-lts Fixed in 1.10.1-lts Patch available GHSA-26w3-q4j8-4xjp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fit2cloud:1panel:*:*:*:*:*:*:*:* | before 1.10.1-lts | Vulnerable | 1Panel-dev |
- cpe:2.3:a:fit2cloud:1panel:*:*:*:*:*:*:*:* Versions before 1.10.1-lts Vulnerable ·1Panel-dev
Remediation
- Fix · CNA 1Panel (1Panel-dev) Fixed in 1.10.1-lts
- Fix · GHSA-26w3-q4j8-4xjp github.com/1Panel-dev/1Panel (Go) Fixed in 1.10.1-lts Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-27288
- 2026-10-03 Alias added: GHSA-26w3-q4j8-4xjp
References
More 1Panel-dev 1panel vulnerabilities
- TI-2024-26801 a sqlinjection in 1Panel CVSS 3.1CRITICAL 9.8
- TI-2023-20859 1Panel arbitrary file write vulnerability exists in the background CVSS 3.1CRITICAL 9.8
- TI-2025-34229 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution CVSS 3.1CRITICAL 9.8
- TI-2024-02187 1Panel swap baseApi.UpdateDeviceSwap command injection CVSS 3.1CRITICAL 9.8
- TI-2025-35333 OS Command injection vulnerability in function OperateSSH in 1panel 2.0.8 allowing… CVSS 3.1HIGH 8.8
- TI-2023-19085 Command injection in firewall ip functionality in 1Panel CVSS 3.1HIGH 8.8
Sources
- CVE-2024-27288 · CVE Program
- CVE-2024-27288 · NVD
- FIRST EPSS
- GHSA-26w3-q4j8-4xjp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences