Read the docs
TI-2024-18802 Aliases CVE-2024-28243GHSA-64fm-8hw2-v72w

KaTeX's maxExpand bypassed by \edef

Priority LOW 32CWE-674Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-674.

Summary

KaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using `\edef` that causes a near-infinite loop, despite setting `maxExpand` to avoid such loops. This can be used as an availability attack, where e.g. a client rendering another user's KaTeX input will be unable to use the site due to memory overflow, tying up the main thread, or stack overflow. Upgrade to KaTeX v0.16.10 to remove this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01414 72nd percentileScored 2026-11-07
Fix Fixed KaTeX (KaTeX): 0.16.10katex (npm): 0.16.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
KaTeXKaTeX0.12.0 to before 0.16.100.16.10Patch availableCNA
—katex (npm)0.12.0 to before 0.16.100.16.10Patch availableGHSA-64fm-8hw2-v72w
  • KaTeX VendorKaTeX Affected 0.12.0 to before 0.16.10 Fixed in 0.16.10 Patch available CNA
  • katex (npm) Vendor— Affected 0.12.0 to before 0.16.10 Fixed in 0.16.10 Patch available GHSA-64fm-8hw2-v72w

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:katex:katex:*:*:*:*:*:*:*:*0.1.0 to before 0.16.10VulnerableKaTeX
  • cpe:2.3:a:katex:katex:*:*:*:*:*:*:*:* Versions 0.1.0 to before 0.16.10 Vulnerable ·KaTeX

Remediation

  • Fix · CNA KaTeX (KaTeX) Fixed in 0.16.10
  • Fix · GHSA-64fm-8hw2-v72w katex (npm) Fixed in 0.16.10 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-28243
  2. 2026-10-03 Alias added: GHSA-64fm-8hw2-v72w

References

  • TI-2024-18803 KaTeX's maxExpand bypassed by Unicode sub/superscripts CVSS 3.1MEDIUM 6.5
  • TI-2025-16992 \htmlData does not validate attribute names in KaTeX CVSS 3.1HIGH 7.2
  • TI-2024-18804 KaTeX's \includegraphics does not escape filename CVSS 3.1MEDIUM 6.3
  • TI-2024-18805 KaTeX is missing normalization of the protocol in URLs allows bypassing forbidden protocols CVSS 3.1MEDIUM 5.5

Sources