Cross Site Scripting vulnerability in LimeSurvey before 6.5.12+240611 allows a remote…
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross Site Scripting vulnerability in LimeSurvey before 6.5.12+240611 allows a remote attacker to execute arbitrary code via a crafted script to the title and comment fields.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00567 47th percentileScored 2026-11-07
Fix Fixed limesurvey/limesurvey (Packagist): 6.5.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | limesurvey/limesurvey (Packagist) | before 6.5.12 | 6.5.12 | Patch available | GHSA-c7xm-rwqj-pgcj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- limesurvey/limesurvey (Packagist) Vendor— Affected before 6.5.12 Fixed in 6.5.12 Patch available GHSA-c7xm-rwqj-pgcj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:limesurvey:limesurvey:*:*:*:*:*:*:*:* | before 6.5.12\+240611 | Vulnerable | LimeSurvey |
- cpe:2.3:a:limesurvey:limesurvey:*:*:*:*:*:*:*:* Versions before 6.5.12\+240611 Vulnerable ·LimeSurvey
Remediation
- Fix · GHSA-c7xm-rwqj-pgcj limesurvey/limesurvey (Packagist) Fixed in 6.5.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-28709
- 2026-10-03 Alias added: GHSA-c7xm-rwqj-pgcj
References
More Limesurvey vulnerabilities
- TI-2020-09194 LimeSurvey before 4.1.12+200324 contains a path traversal vulnerability in… CVSS 3.1CRITICAL 9.8
- TI-2024-28662 An issue in the js_localize.php function of LimeSurvey v6.6.2 and before allows attackers… CVSS 3.1HIGH 8.8
- TI-2024-26167 Lime Survey <= 6.5.12 is vulnerable to Cross Site Request Forgery (CSRF). CVSS 3.1HIGH 8.8
- TI-2022-21122 LimeSurvey before v5.0.4 was discovered to contain a SQL injection vulnerability via the… CVSS 3.1HIGH 7.2
- TI-2007-03523 Multiple PHP remote file inclusion vulnerabilities in LimeSurvey (aka PHPSurveyor)… CVSS 2.0MEDIUM 6.8
- TI-2018-12189 An issue was discovered in TCPDF before 6.2.22. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2024-28709 · CVE Program
- CVE-2024-28709 · NVD
- FIRST EPSS
- GHSA-c7xm-rwqj-pgcj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences