Read the docs
TI-2024-18988 Aliases CVE-2024-28754GHSA-vc9f-mgxr-h32r

RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent…

Priority MEDIUM 40Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent denial of service (bricking) via a crafted request.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00856 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed billz/raspap-webgui (Packagist): 3.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—billz/raspap-webgui (Packagist)before 3.1.03.1.0Patch availableGHSA-vc9f-mgxr-h32r
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • billz/raspap-webgui (Packagist) Vendor— Affected before 3.1.0 Fixed in 3.1.0 Patch available GHSA-vc9f-mgxr-h32r

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:raspap:raspap:*:*:*:*:*:*:*:*up to 3.0.9VulnerableRaspAP
  • cpe:2.3:a:raspap:raspap:*:*:*:*:*:*:*:* Versions up to 3.0.9 Vulnerable ·RaspAP

Remediation

  • Fix · GHSA-vc9f-mgxr-h32r billz/raspap-webgui (Packagist) Fixed in 3.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-28754
  2. 2026-10-03 Alias added: GHSA-vc9f-mgxr-h32r

References

  • TI-2022-18933 A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated… CVSS 3.1CRITICAL 9.8
  • TI-2022-18934 A Command injection vulnerability in RaspAP 2.8.0 thru 2.9.2 allows an authenticated… CVSS 3.1HIGH 8.8
  • TI-2024-02323 RaspAP raspap-webgui HTTP POST Request provider.php code injection CVSS 3.1HIGH 7.2
  • TI-2021-12821 A vulnerability exists in RaspAP 2.6 to 2.6.5 in the "iface" GET parameter in… CVSS 3.1CRITICAL 9.8
  • TI-2021-16152 includes/configure_client.php in RaspAP 2.6.6 allows attackers to execute commands via command injection. CVSS 3.1HIGH 8.8
  • TI-2020-15053 An issue was discovered in includes/webconsole.php in RaspAP 2.5. CVSS 3.1HIGH 8.8
See all 11 →

Sources