DoS via a large number of User Preferences
Priority LOW 30CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Mattermost Server versions 9.5.x before 9.5.2, 9.4.x before 9.4.4, 9.3.x before 9.3.3, 8.1.x before 8.1.11 don't limit the number of user preferences which allows an attacker to send a large number of user preferences potentially causing denial of service.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00562 46th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 9.6.0, 9.5.2, 9.4.4 +2github.com/mattermost/mattermost/server/v8 (Go): 8.1.11, 9.3.3, 9.4.4 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 9.5.0 – 9.5.1; 9.4.0 – 9.4.3; 9.3.0 – 9.3.2; 8.1.0 – 8.1.10 | 9.6.0, 9.5.2, 9.4.4, 9.3.3, 8.1.11 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 8.1.0 to before 8.1.11 | 8.1.11 | Patch available | GHSA-mcw6-3256-64gg |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.3.0 to before 9.3.3 | 9.3.3 | Patch available | GHSA-mcw6-3256-64gg |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.4.0 to before 9.4.4 | 9.4.4 | Patch available | GHSA-mcw6-3256-64gg |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.5.0 to before 9.5.2 | 9.5.2 | Patch available | GHSA-mcw6-3256-64gg |
- Mattermost VendorMattermost Affected 9.5.0 – 9.5.1; 9.4.0 – 9.4.3; 9.3.0 – 9.3.2; 8.1.0 – 8.1.10 Fixed in 9.6.0, 9.5.2, 9.4.4, 9.3.3, 8.1.11 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 8.1.0 to before 8.1.11 Fixed in 8.1.11 Patch available GHSA-mcw6-3256-64gg
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.3.0 to before 9.3.3 Fixed in 9.3.3 Patch available GHSA-mcw6-3256-64gg
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.4.0 to before 9.4.4 Fixed in 9.4.4 Patch available GHSA-mcw6-3256-64gg
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.5.0 to before 9.5.2 Fixed in 9.5.2 Patch available GHSA-mcw6-3256-64gg
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 8.1.0 to before 8.1.11; 9.3.0 to before 9.3.3; 9.4.0 to before 9.4.4; 9.5.0 to before 9.5.2 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 8.1.0 to before 8.1.11; 9.3.0 to before 9.3.3; 9.4.0 to before 9.4.4; 9.5.0 to before 9.5.2 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 9.6.0, 9.5.2, 9.4.4, 9.3.3, 8.1.11
- Fix · GHSA-mcw6-3256-64gg github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.1.11 Advisory →
- Fix · GHSA-mcw6-3256-64gg github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.3.3 Advisory →
- Fix · GHSA-mcw6-3256-64gg github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.4.4 Advisory →
- Fix · GHSA-mcw6-3256-64gg github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.5.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-28949
- 2026-10-03 Alias added: GHSA-mcw6-3256-64gg
References
Other 5
- https://github.com/mattermost/mattermost/commit/11a21f4da352a472a09de3b8e125514750a6619a
- https://github.com/mattermost/mattermost/commit/362b7d29d35c00fe80721d3d47442a4f3168eb2b
- https://github.com/mattermost/mattermost/commit/5632d6b4ff6d019a21bb8ddd037d4a931cd85ae2
- https://github.com/mattermost/mattermost/commit/88f9285173dc4cb35fa19a8b8604e098a567f704
- https://pkg.go.dev/vuln/GO-2024-2695
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-28949 · CVE Program
- CVE-2024-28949 · NVD
- FIRST EPSS
- GHSA-mcw6-3256-64gg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences