Cross-site scripting in Saturday Drive Ninja Forms
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Ninja Forms prior to 3.8.1 contains a cross-site scripting vulnerability in custom fields for labels. If this vulnerability is exploited, an arbitrary script may be executed on the web browser of the user who is accessing to the website using the product.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00454 39th percentileScored 2026-11-07
Fix Fixed Ninja Forms (Saturday Drive): 3.8.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Saturday Drive | Ninja Forms | before 3.8.1 | 3.8.1 | Patch available | CNA |
- Ninja Forms VendorSaturday Drive Affected before 3.8.1 Fixed in 3.8.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ninjaforms:ninja_forms:*:*:*:*:*:wordpress:*:* | before 3.8.1 | Vulnerable | Saturday Drive |
- cpe:2.3:a:ninjaforms:ninja_forms:*:*:*:*:*:wordpress:*:* Versions before 3.8.1 Vulnerable ·Saturday Drive
Remediation
- Fix · CNA Ninja Forms (Saturday Drive) Fixed in 3.8.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-29220
- 2026-10-03 Alias added: GHSA-72h6-54fg-6qph
References
More Saturday Drive Ninja Forms vulnerabilities
- TI-2025-08325 Ninja-forms < 3.11.1 - Unauthenticated PHP Objection CVSS 3.1CRITICAL 9.8
- TI-2016-01107 The Ninja Forms plugin before 2.9.42.1 for WordPress allows remote attackers to conduct… CVSS 3.0CRITICAL 9.8
- TI-2023-19777 WordPress Ninja Forms plugin <= 3.6.25 - Subscriber+ Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2022-02691 NinjaForms < 3.6.13 - Admin+ PHP Objection Injection CVSS 3.1HIGH 7.2
- TI-2024-06815 Ninja Forms 3.8.6-3.8.10 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2023-01723 Ninja Forms < 3.6.22 - Reflected XSS CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-29220 · CVE Program
- CVE-2024-29220 · NVD
- FIRST EPSS
- GHSA-72h6-54fg-6qph · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences