NodeBB 3.6.7 is vulnerable to Incorrect Access Control, e.g., a low-privileged attacker…
Priority LOW 28Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
NodeBB 3.6.7 is vulnerable to Incorrect Access Control, e.g., a low-privileged attacker can access the restricted tabs for the Admin group via "isadmin":true.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0043 37th percentileScored 2026-11-07
Fix Fixed nodebb (npm): 3.6.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | nodebb (npm) | before 3.6.7 | 3.6.7 | Patch available | GHSA-qc99-r4wh-c8h6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- nodebb (npm) Vendor— Affected before 3.6.7 Fixed in 3.6.7 Patch available GHSA-qc99-r4wh-c8h6
Remediation
- Fix · GHSA-qc99-r4wh-c8h6 nodebb (npm) Fixed in 3.6.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-29316
- 2026-10-03 Alias added: GHSA-qc99-r4wh-c8h6
References
More Nodebb vulnerabilities
- TI-2023-23124 A remote code execution (RCE) vulnerability in the xmlrpc.php endpoint of NodeBB Inc… CVSS 3.1CRITICAL 9.8
- TI-2022-22808 Account takeover via prototype vulnerability CVSS 3.1CRITICAL 9.8
- TI-2026-42173 NodeBB - ActivityPub Author Spoofing via Unvalidated attributedTo Mapped to Local User CVSS 4.0HIGH 8.7
- TI-2025-32286 NodeBB v4.3.0 is vulnerable to SQL injection in its search-categories API endpoint… CVSS 3.1HIGH 8.6
- TI-2023-14416 NodeBB Pre-Authentication Denial-of-Service CVSS 3.1HIGH 7.5
- TI-2022-16499 Account takeover via SSO plugins in NodeBB CVSS 3.1HIGH 8.8
Sources
- CVE-2024-29316 · CVE Program
- CVE-2024-29316 · NVD
- FIRST EPSS
- GHSA-qc99-r4wh-c8h6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences