Malicious remote can create arbitrary reactions on arbitrary posts
Priority LOW 20CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6 fail to properly validate synced reactions, when shared channels are enabled, which allows a malicious remote to create arbitrary reactions on arbitrary posts
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00276 20th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 9.10.0, 9.9.1, 9.5.7github.com/mattermost/mattermost/server/v8 (Go): 9.5.7, 9.9.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 9.9.0; 9.5.0 – 9.5.6 | 9.10.0, 9.9.1, 9.5.7 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.5.0 to before 9.5.7 | 9.5.7 | Patch available | GHSA-jq3g-xqpx-37x3 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.9.0 to before 9.9.1 | 9.9.1 | Patch available | GHSA-jq3g-xqpx-37x3 |
- Mattermost VendorMattermost Affected 9.9.0; 9.5.0 – 9.5.6 Fixed in 9.10.0, 9.9.1, 9.5.7 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.5.0 to before 9.5.7 Fixed in 9.5.7 Patch available GHSA-jq3g-xqpx-37x3
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.9.0 to before 9.9.1 Fixed in 9.9.1 Patch available GHSA-jq3g-xqpx-37x3
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* | 9.5.0 to before 9.5.7 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost:9.9.0:*:*:*:*:*:*:* | 9.9.0 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* Versions 9.5.0 to before 9.5.7 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost:9.9.0:*:*:*:*:*:*:* Versions 9.9.0 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 9.10.0, 9.9.1, 9.5.7
- Fix · GHSA-jq3g-xqpx-37x3 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.5.7 Advisory →
- Fix · GHSA-jq3g-xqpx-37x3 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.9.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-29977
- 2026-10-03 Alias added: GHSA-jq3g-xqpx-37x3
References
More Mattermost vulnerabilities
- TI-2024-26695 Malicious remote can invite itself to an arbitrary local channel CVSS 3.1CRITICAL 9.6
- TI-2023-02056 Oauth authorization codes do not expire when deauthorizing an oauth2 app CVSS 3.1CRITICAL 9.1
- TI-2019-15069 An issue was discovered in Mattermost Mobile Apps before 1.26.0. CVSS 3.1CRITICAL 9.1
- TI-2024-26233 Malicious remote can add users to arbitrary teams and channels CVSS 3.1HIGH 8.7
- TI-2024-26746 Permanently local data deletion by malicious remote CVSS 3.1HIGH 8.7
- TI-2023-06508 Injection in Mattermost CVSS 3.1HIGH 8.8
Sources
- CVE-2024-29977 · CVE Program
- CVE-2024-29977 · NVD
- FIRST EPSS
- GHSA-jq3g-xqpx-37x3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences