PsiTransfer file integrity violation vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-434.
Summary
PsiTransfer is an open source, self-hosted file sharing solution. Prior to version 2.2.0, the absence of restrictions on the endpoint, which is designed for uploading files, allows an attacker who received the id of a file distribution to change the files that are in this distribution. The vulnerability allows an attacker to influence those users who come to the file distribution after them and slip the victim files with a malicious or phishing signature. Version 2.2.0 contains a patch for this issue. CVE-2024-31454 allows users to violate the integrity of a file that is uploaded by another user. In this case, additional files are not loaded into the file bucket. Violation of integrity at the level of individual files. While the vulnerability with the number CVE-2024-31453 allows users to violate the integrity of a file bucket without violating the integrity of files uploaded by other users. Thus, vulnerabilities are reproduced differently, require different security recommendations and affect different objects of the application’s business logic.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| psi-4ward | psitransfer | before 2.2.0 | 2.2.0 | Patch available | CNA |
| — | psitransfer (npm) | before 2.2.0 | 2.2.0 | Patch available | GHSA-2p2x-p7wj-j5h2 |
- psitransfer Vendorpsi-4ward Affected before 2.2.0 Fixed in 2.2.0 Patch available CNA
- psitransfer (npm) Vendor— Affected before 2.2.0 Fixed in 2.2.0 Patch available GHSA-2p2x-p7wj-j5h2
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:psi-4ward:psitransfer:*:*:*:*:*:*:*:* | — | — | — |
- cpe:2.3:a:psi-4ward:psitransfer:*:*:*:*:*:*:*:* Versions — — ·—
Remediation
- Fix · CNA psitransfer (psi-4ward) Fixed in 2.2.0
- Fix · GHSA-2p2x-p7wj-j5h2 psitransfer (npm) Fixed in 2.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-31454
- 2026-10-03 Alias added: GHSA-2p2x-p7wj-j5h2
References
More psi-4ward vulnerabilities
- TI-2026-29803 PsiTransfer: Upload PATCH path traversal can create `config.<NODE_ENV>.js` and lead to code execution on restart CVSS 3.1HIGH 7.5
- TI-2024-20817 PsiTransfer vulnerable to violation of the integrity of file distribution CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-31454 · CVE Program
- CVE-2024-31454 · NVD
- FIRST EPSS
- GHSA-2p2x-p7wj-j5h2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences