PsiTransfer: Upload PATCH path traversal can create `config.<NODE_ENV>.js` and lead to code execution on restart
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
PsiTransfer is an open source, self-hosted file sharing solution. Prior to version 2.4.3, the upload PATCH flow under `/files/:uploadId` validates the mounted request path using the still-encoded `req.path`, but the downstream tus handler later writes using the decoded `req.params.uploadId`. In deployments that use a supported custom `PSITRANSFER_UPLOAD_DIR` whose basename prefixes a startup-loaded JavaScript path, such as `conf`, an unauthenticated attacker can create `config.<NODE_ENV>.js` in the application root. The attacker-controlled file is then executed on the next process restart. Version 2.4.3 contains a patch.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| psi-4ward | psitransfer | before 2.4.3 | 2.4.3 | Patch available | CNA |
| — | psitransfer (npm) | before 2.4.3 | 2.4.3 | Patch available | GHSA-533q-w4g6-5586 |
- psitransfer Vendorpsi-4ward Affected before 2.4.3 Fixed in 2.4.3 Patch available CNA
- psitransfer (npm) Vendor— Affected before 2.4.3 Fixed in 2.4.3 Patch available GHSA-533q-w4g6-5586
Remediation
- Fix · CNA psitransfer (psi-4ward) Fixed in 2.4.3
- Fix · GHSA-533q-w4g6-5586 psitransfer (npm) Fixed in 2.4.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-41180
- 2026-10-03 Alias added: GHSA-533q-w4g6-5586
References
More psi-4ward vulnerabilities
- TI-2024-20818 PsiTransfer file integrity violation vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-20817 PsiTransfer vulnerable to violation of the integrity of file distribution CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-41180 · CVE Program
- CVE-2026-41180 · NVD
- FIRST EPSS
- GHSA-533q-w4g6-5586 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences